Mein Quad stottert - Hilfe!

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Mein Quad stottert - Hilfe!

      Moin,
      ich fliege seit ca. einem Jahr folgendes Setup:
      Dquad xt190
      Naze32 Rev. 6
      LittleBee 20A
      T-Motor F60 2200KV
      4S Graphene/Mylipo Parcour

      Seit dem letzten Wochenende stottern mein Quad, wenn ich nach nem Gasschub den Copter schweben lasse. Das fing am Sonntag Nachmittag nach einem Akkuwechsel an.

      Gestern habe ich den Copter mal ohne Props getestet, da war wieder alles wie gewohnt. Heute hab ich im Garten dann noch mal einen Probeflug gemacht. Zuerst schien alles okay, aber nach ein paar Sekunden schweben fing der Copter wieder an zu zucken. Dabei zuckt er nicht unkontrolliert in verschiedene Richtungen, sondern sackt komplett ab, er hüpft quasi. Nach den 30 Sekunden Tests waren die Motoren bereits handwarm und auch die ESCs, die sich sonst kaum erwärmen, waren handwarm.

      Habt ihr eine Idee, woran as wohl liegen kann? Am Sonntag war es sehr warm und ich hab den Copter ordentlich über den Racetrack gejagt. Ich bin diverse Male abgestürzt, beim letzten Akkuwechsel allerdings nicht.

      Was könnte ich denn nun testen, um dem Problem auf die Schliche zu kommen? Ohne Props scheint er ja ganz normal zu regeln...

      Über Hilfe würde ich mich sehr freuen!

      Gruß, Ingo
      DQuad XT190: Naze32 Rev.6|T-Motor F60 V2|20A LittleBee|4S Lipo|DSMX Sat|HQprops 5x4x3|WS2812 -> 505g
      YT Playlist
    • simon.bethke schrieb:

      Könnten failsafes sein... Hast du direkt 'drop' ohne Verzögerung?
      Grad noch mal getestet, mit frischen props. ja, ohne verzögerung, der copter schwebt vor mir, so 10-50cm höhe. in den ersten sekunden ist alles normal, dann dropt er wieder. Gefühlt gehen alle Motoren für einen Bruchteil einer Sekunde aus und wieder an.

      BB-Log ist ne gute Idee, mach ich gleich direkt. Was und in welcher Auflösung logge ich denn dann am Besten? Das Naze32 hat ja nicht den größten Speicher.
      DQuad XT190: Naze32 Rev.6|T-Motor F60 V2|20A LittleBee|4S Lipo|DSMX Sat|HQprops 5x4x3|WS2812 -> 505g
      YT Playlist
    • EumelOne schrieb:

      Evtl waren die Motoren zu heiß, was eine Demagnetisierung zur Folge haben könnte. Dadurch fehlt dann einfach die gewohnte Leistung, was das durchsacken erklären könnte.

      Evtl. Solltest Du aber auch einfach mal zum Logopäden mit ihm gehen wenn er stotter, evtl weiß der was :D
      :D haha, ja, der guckt dann bestimmt doof! also bei fehlender leistung würde ich anderes verhalten erwarten. es wirkt eher so wie bei einem benzinauto, wenn der luftblasen im spritschlauch sind. vielleicht krieg ich ja ein video hin...

      Gruß, Ingo
      DQuad XT190: Naze32 Rev.6|T-Motor F60 V2|20A LittleBee|4S Lipo|DSMX Sat|HQprops 5x4x3|WS2812 -> 505g
      YT Playlist
    • MCWallFly schrieb:

      Also ich hatte mal bei einem Quad mitten im Flug oftmals "Telemetrie lost".
      Alle Lötstellen sahen gut aus.Dann habe ich das XT60 Kabel neu angelötet und zack auf einmal keine Verbindungsunterbrechung.
      Einfach mal ausprobieren
      das ist interessant - mir ist vor kurzem ein xt60 stecker festgeschmolzen, weil der pin zu weit zusammengedrückt war und nicht genug auflagefläche zur buchse hatte. diese hab ich nur einmal sauber gemacht und einen holzstift in die pins gedrückt.

      Gruß, Ingo
      DQuad XT190: Naze32 Rev.6|T-Motor F60 V2|20A LittleBee|4S Lipo|DSMX Sat|HQprops 5x4x3|WS2812 -> 505g
      YT Playlist
    • So, neue Infos,

      hab mal ein Video gemacht und BB aufgenommen. Mit den neuen Props verhält er sich geringfügig anders. Wenn ich allerdings etwas mehr Schub gebe und dieses Zittern anfängt, schaukelt sich das Quad selbst immer höher...



      Anbei auch das BB-Log. Wonach sollte ich denn nun wohl schauen? Hab mich bisher kaum damit auseinander gesetzt. Aufgrund des Tipps mit dem xt60-Stecker hab ich mir VBat angeschaut. Das ist schon sehr auffällig, dass dort bei oder kurz vor den Zitteranfällen oft die Spannung bis auf 8,XXV einbricht...

      Die angehängte Datei herunterladen und evtl. die Dateiendung auf .BFL ändern, musste sie umbenennen, damit das Forum den Anhang akzeptiert.

      Gruß, Ingo
      Dateien
      DQuad XT190: Naze32 Rev.6|T-Motor F60 V2|20A LittleBee|4S Lipo|DSMX Sat|HQprops 5x4x3|WS2812 -> 505g
      YT Playlist

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von HeaDd ()

    • Ich glaub du hast gyro-glitches. Der Gyro ist ggf. hinüber.

      Wie komme ich darauf?
      Ich hab das Blackboxlog angeschaut und sehe, dass immer Motorpaare hochdrehen. Das spricht dafür, dass der MotorMix nen fehlerhaften Input bekommt. Aus dem RC Command kommt es auf jedenfall nicht.
      Zuerst sah das alles ziemlich seltsam aus, weil es schien als würden die Motoransteuerungsfehler vor dem Gyro kommen. Jedoch ist dies nicht der fall. Mit dem Hotkey "S" kann man smoothing ausschalten. Danach ist problemlos zu sehen, dass Gyroausschläge (Gyroglitches) mit den Motoransteuerungen gleichzeitig kommen.

      Die Frage die sich jetzt stellt ist, ob der Gyro ein reversibles Problem hat oder nicht. Ich hatte mal nen 'kaputten' gyro, bei dem ich nur die Beinchen des ICs etwas gesäubert hatte und dann funktionierte er wieder super. Auch hab ich schon gehört, dass FCs mit VReg onboard eher zu gyroglitches tendieren.
      Ausschließlich in der Mitte von Nix zu schweben macht mich depressiv!
    • simon.bethke schrieb:

      Ich glaub du hast gyro-glitches. Der Gyro ist ggf. hinüber.

      Wie komme ich darauf?
      Ich hab das Blackboxlog angeschaut und sehe, dass immer Motorpaare hochdrehen. Das spricht dafür, dass der MotorMix nen fehlerhaften Input bekommt. Aus dem RC Command kommt es auf jedenfall nicht.
      Zuerst sah das alles ziemlich seltsam aus, weil es schien als würden die Motoransteuerungsfehler vor dem Gyro kommen. Jedoch ist dies nicht der fall. Mit dem Hotkey "S" kann man smoothing ausschalten. Danach ist problemlos zu sehen, dass Gyroausschläge (Gyroglitches) mit den Motoransteuerungen gleichzeitig kommen.

      Die Frage die sich jetzt stellt ist, ob der Gyro ein reversibles Problem hat oder nicht. Ich hatte mal nen 'kaputten' gyro, bei dem ich nur die Beinchen des ICs etwas gesäubert hatte und dann funktionierte er wieder super. Auch hab ich schon gehört, dass FCs mit VReg onboard eher zu gyroglitches tendieren.
      Hi Simon,
      danke dass du dich damit so intensiv auseinander setzt! :thumbup: Ich kann aus dem Log kaum Schlussfolgerungen ziehen. Das Säubern werd ich aber direkt als nächstes versuchen. Im Tower selbst sieht es aus wie auf ner Wiese, neben kleinen Halben sind wohl auch viele Stellen mit einem grünen Film überzogen. :saint:

      Wie und womit mach ich das FC denn am besten sauber ohne es zu beschädigen?

      Gruß, Ingo
      DQuad XT190: Naze32 Rev.6|T-Motor F60 V2|20A LittleBee|4S Lipo|DSMX Sat|HQprops 5x4x3|WS2812 -> 505g
      YT Playlist
    • Ich glaub das mit dem deaktivieren der ersten beiden Filter ist nicht die Ursache. Allerdings musst du zum einen auch die anderen Filter auf PT1 stellen und zum anderen würde ich nochmal hinterfragen, ob das Konzept mit nem F1 funktionieren kann.

      Zum reinigen hab ich leider keinen guten Vorschlag. Der gyro ist ja nicht der F1 IC sondern ein kleiner quadratischer IC mit 2-3mm kantenlänge daneben.

      Ich hatte die Beinchen vorsichtig rein mechanisch mit der sonde von nem Multimeter 'gereinigt'.
      Ausschließlich in der Mitte von Nix zu schweben macht mich depressiv!
    • Für mich hört es sich wie ein Timingproblem der Motoren an. Solch "geklackere" der Motoren hatte ich auch schon mal mit älteren ESC's und DShot150 (glaube ich, auf jeden Fall etwas mit DShot). Das Geräusch schien direkt aus den Motorglocken zu kommen.
      Hab dann zurückgestellt auf Oneshot125 und das Geräusch war weg.
      Es kann auch eine falsche Timingeinstellung der ESC's sein, nur die ändert sich ja normalerweise nicht von alleine.
      Built - Fly - Crash - Repeat ^^
      - Realacc X210, Realacc XS220, Diatone Grashopper-160, Reptile RX130, Realacc QQX-130