BetaFlight RC-Totzone (Deadband)

    • BetaFlight RC-Totzone (Deadband)

      Neu

      Hey Leute,

      ich habe das Problem, dass die Sticks meiner Turnigy 9x nicht perfekt zentrieren, wenn ich sie loslasse. Im BetaFlight-Konfigurator sehe ich, dass es manchmal einen Offset zur Nullage von ca. 10-15 (Mitte bei 1500) gibt. Dies betrifft Roll/Pitch und Yaw.

      Das ist sehr störend, da sich mein Copter im Schwebeflug oder beim einfachen Geradeausfliegen immer langsam dreht, am meisten merke ich das beim Rollen, denn ich muss ständig dagegenregeln, was in ein permantenes leichtes Schaukeln resultiert und unschön anzusehen ist.

      Daher habe ich an der Deadband-Einstellungen herumgespielt, aber irgendwie scheint das nicht zu funktionieren. Selbst wenn ich eine Totzone von +-30 einstelle, kann ich sehen, wie der Copter in der Vorschau langsam dreht, obwohl der Wert durch die Totzone eigentlich berücksichtigt werden müsste. Bei +-30 müssten eigentlich die Werte von 1470 bis 1530 komplett auf 1500 gesetzt werden, was aber nicht der Fall ist.

      Weiß vielleicht jemand, warum? Oder ist die Darstellung der Totzone vielleicht einfach nicht in der Vorschau berücksichtigt?
      Ich fliege übrigens BetaFlight 3.1.7.

      Danke ;)
    • Neu

      Wie wäre es alternative die RC einzustellen das er nicht so viel Abweichung hat ?

      Bei fast allen rc kann man auch die Sticks kalibrieren und dann mit subtrim auf Mitte bringen ...

      Wie lange er diese Einstellung hält ist dann wieder ne andere Sache.

      Die tot zone ist aber mehr dafür da wenn die zahlen nicht stabil gehalten werden ... Sprich ohne dein zutun springen sie um +/- 5 z.b dann sollte da mit dem wert von 6 das ausgeglichen werden . die Anzeige macht bei mir auch kein unterschied ob ich da 2 oder 10 drin habe
    • Neu

      Hey!
      Also ich habe die RC schon versucht einzustellen, also mehrfaches Kalibrieren der Knüppelpotis. Trimmen bringt meiner Meinung nach nichts, da es keinen konstanten Offset gibt und schon gar nicht in die selbe Richtung. Mal kann der Wert 1500+6 sein, dann nach einer Bewegung kann er 1500-4 betragen.

      Ich denke das ist rein mechanisch geschuldet, da ich keinen Jitter auf den Signalen habe, sondern die Sticks einfach nicht immer perfekt in die Nulllage zurückkehren. Da reicht häufig schon ein leichtes berühren der Sticks aus und die Werte liegen wieder auf 1500, wenn sie vorher z.B. auf 1494 waren oder so. Ich glaube die Gimbals sind einfach nicht so toll, war und ist halt mein erster Sender :thumbup:

      Frage aus Interesse: Zentrieren eure Knüppel/Werte wieder immer perfekt auf 1500, wenn ihr diese loslasst?
    • Neu

      MeisterEder schrieb:

      Hatte ich auch, das Problem mit meiner Turnigy 9XR Pro, das liegt an den schlechten Gimbals. Habe dann einfach in der Funke unter dem Hardware-Menü Deadband für die Sticks höher gestellt, seitdem ist Ruhe.
      In das Menü kommst du, wenn du die vom linken Knüppel die Subtrim-Taste für Yaw (bei Mode 2) beim Einschalten nach links drückst.
      Hey MeisterEder!

      Danke für den Hinweis, das wusste ich gar nicht, werde ich mir später mal anschauen!
      Bezieht sich das auf die Standardsoftware? Ich habe nämlich er9x drauf.

      Danke :)
    • Neu

      Das bezieht sich auf ErSky9X, das Hardware-Menü müsste aber auch auf der Standardsoftware dabei sein.

      Zu deiner Frage: Mit der richtigen Deadband-Einstellung (bitte nur so hoch wie nötig) und SBUS-Empfänger zentriert dann der Knüppel immer genau auf 1500. Bei PPM-Empfängern wackeln die Werte ein bisschen (so um 1-2), da empfiehlt sich zusätzlich Deadband in Betaflight.
    • Neu

      Hey!

      Also ich habe es leider nicht hinbekommen.
      Meine er9x-Software unterstützt kein Deadband, ich komme nichtmal ins Hardware-Menü, obwohl ich alle im Internet findbaren Schalterkombis beim Einschalten getestet habe. Im eepe-Konfigurator gibts zwar die Hardwareeinstellungen, jedoch kein Deadband :( Dann habe ich versucht Kurven selbst zu definieren für das Deadband, jedoch kann man nur die y-Werte einstellen, keine x-Werte, daher ist das für mich unbrauchbar.

      Dann habe ich mir companion geladen und openTX auf meine 9x gezogen. Die Software ist schon um einiges fortschrittlicher und bietet auch Kurven an, bei denen man die x/y-Werte frei vorgeben kann.
      Das Problem hier: Ich habe ein XJT-Modul in meiner 9x und openTX bietet kein PXX-Protokoll sodass ich mein Modul nicht nutzen kann, richtig?

      Gibts noch Alternativen?

      VG!
    • Neu

      multirotor schrieb:

      Man kann im Mixer die Funktion x<0 und x>0 verwenden, um einen Offset vom Nullpunkt in [%] zu definieren, siehe im folgenden Bild


      Dies hat genau den von mir gewünschten Effekt, es gibt nun keinen Drift mehr :)
      Und wenn du den Offset variabel haben willst weil deine Sticks immer mehr ausleiern, legst du den Prozentwert auf eine globale Variable :thumbup:

      bind.ing schrieb:

      is immer zwiespältig mit dir Fliegen gehn, mei soziale Ader freut si, mei Fliegerego geht in a Ecke weinen :thumbsup:

    • Neu

      MeisterEder schrieb:

      Ansonsten installiere mal hier die neueste, die geht echt super, auch die FrSky-Telemetrie ohne Kabel: openrcforums.com/forum/viewtop…c671f193acb5b1ebfcc350ea4
      Danke für den Tipp!
      Hab mir mal die neueste Version heruntergeladen, aber bei mir läuft das nicht. Ich hab ja auch die alte 9x mit dem ATMega 2560, musste daher auch exta die "small"-Version nehmen. Bei mir bleibt aber das Display einfach leer, nichts passiert, Läuft ersky9x überhaupt auf der alten 9x? Ich glaub fast nicht :D


      Baufritz schrieb:

      multirotor schrieb:

      Man kann im Mixer die Funktion x<0 und x>0 verwenden, um einen Offset vom Nullpunkt in [%] zu definieren, siehe im folgenden Bild


      Dies hat genau den von mir gewünschten Effekt, es gibt nun keinen Drift mehr :)
      Und wenn du den Offset variabel haben willst weil deine Sticks immer mehr ausleiern, legst du den Prozentwert auf eine globale Variable :thumbup:
      Super Tipp, hab ich vorher gar nicht in Betracht gezogen, läuft gut mit den globalen Variablen :thumbup: