FrSky R-XSR -- Keine Ausschläge in Betaflight

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • FrSky R-XSR -- Keine Ausschläge in Betaflight

      Hallo Zusammen liebe Copter-Freunde,

      ich bin ziemlich neu im Forum und im Hobby und habe mich nach einiger Recherche dazu entschieden einen eigenen Copter zu bauen. Hat auch alles soweit geklappt, bis ich dann zum Konfigurieren im Betaflight kam.
      Hier zeigen sich im Empfänger-Tab keine Bewegungen der einzelnen Kanäle. Hab schon alles mögliche ausprobiert und bin jetzt mit meinem Latein am Ende.

      Vielleicht hat von Euch noch jemand eine Idee, was ich übersehen haben könnte. Im folgenden mal kurz mein Setup umrissen und welche Schritte ich jetzt schon ausprobiert hab:

      Setup:
      • FC: Holybro Kakute F7
      • Empfänger: FrSky R XSR
      • Funke: Taranis XQ7S
      Alle Komponenten sind bei Hobby-King gekauft. Im Anschluss hatte ich Empfänger sowie Funke auf die aktuelle LBT-Version geflasht.

      Vorgehen bisher
      Da ich wie gesagt relativ neu im Hobby bin, schreibe ich mal alle meine Arbeitsschritte im Detail auf - vielleicht habe ich ja was grundlegendes übersehen:
      1. FC (Kakute F7) und Empfänger (R-XSR) zusammengelötet: S.Port-Kabel des R-XSR mit dem UART T4 des FC verbunden (Hatte in einem Video von Mirko FPV gesehen, dass man das SBUS-Kabel auch weglassen kann)
        Dann die GND und +5V Anschlüsse vom FC und dem Empfänger verbunden - ich häng noch ein Bild zur besseren Übersicht mit dran.
      2. Aktuelle Betaflight mit notwendigen Treibern installiert (CP210x und die STM USB VCP Treiber)
      3. Aktuelle LBT-Versionen für die Taranis heruntergeladen --> internes XJT-Modul und die Taranis selber mit den aktuellen LBT-Versionen geflasht
      4. Dann den R-XSR-Empfänger ebenfalls mit der aktuellen LBT-Firmware geflasht
      5. Den Kakute F7 mit dem PC verbunden und den ImpulseRC_Driver_Fixer laufen lassen --> FC in den DFU-Modus gebracht und die aktuellen Firmware auf den Kakute F7 geflasht
      6. Danach Betaflight geöffnet, den FC connected und im Anschluss-Tab bei UART 4 den SerialRx aktiviert, dann im Konfigurations-Tab bei Receiver den Serial Based Receiver und als Protokoll FrSky F.Port gewählt
      7. Im Anschluss dann Empfänger und die Taranis-Funke gebunden - hat soweit meines Erachtens nach alles funktioniert: die Kontroll-LEDs am Empfänger leuchten bei eingeschalteter Funke dauerhaft blau (SBUS-Modus) und grün (Empfänger gebunden)
      Und an diesem Punkt habe ich mein Problem:
      Nun würde ich gern die Kanäle den einzelnen Funktionen zuweisen - Aber leider scheint im Betaflight sich kein Balken im Empfänger-Tab zu bewegen, wenn ich die Knüppel der Funke bewege. Hab schon probiert im Betaflight den Serial-Rx zu invertieren aber ohne Erfolg. Muss ich vielleicht an der Funke noch irgendwelche Einstellungen vornehmen?

      Würde mich riesig freuen, wenn jemand eine Idee hätte, was ich übersehen haben könnte.

      Gruß
      Julian
      Bilder
      • Kakute F7 + R-XSR.jpg

        613,5 kB, 1.693×2.257, 60 mal angesehen
    • Hallo Martin,

      vielen Dank für deine Hilfe. So etwas hatte ich mir auch schon gedacht, als ich mir am Anfang die Löt-Pins am FC angeschaut hatte. Dann hatte ich aber ein Video bei Youtube gesehen, bei dem nur der Tx-UART und das FPORT-Protokoll verwendet wurde. Über diese Konfiguration kann man dann den Rx UART vom SBUS-Kabel laut Video einsparen.

      Schau mal hier (Untertitel sind in deutsch): youtube.com/watch?v=77lNkItg-90

      Ich werde aber morgen das SBUS-Kabel anklemmen und dein Vorschlag mal ausprobieren.

      LG
      Julian
    • KampfGurke schrieb:

      Du musst dafür aber auch die Fport Firmware auf den Empfänger Flashen!
      Mit der normalen klappt das nicht...

      frsky-rc.com/wp-content/upload…/FW-RXSR-FPORT-190311.zip

      Ich nutz eigentlich überall Fport !
      oscarliang.com/setup-frsky-fport/
      Habe jetzt mal die Fport-Firmware draufgespielt - vorher war aber auch schon eine ältere Fport-Firmware oben gewesen --> leider immer noch die gleiche Erscheinung. Das gleiche auch wieder, wenn ich den SBUS-Port vom Empfänger am Rx des FC anschließe und das SBUS-Protokoll auswähle ||

      Mir ist jetzt aber aufgefallen, dass wenn ich Betaflight aufmache die RXLOSS-Flag ansteht - liegt da vielleicht der Hase im Pfeffer begraben?
    • Einfach mal mit diesen settings Rum spielen bzw nacheinander halt durch versuchen...

      serialrx_halfduplex = ON serialrx_inverted = ON

      Mal beides on je eins Off oder beide Off irgendwann geht's :)

      Hast aber das Sport Kabel an den TX Port vom UART gelötet nicht RX oder?

      Sbus geht mit der fport Firmware nicht, zumindest bei einer älteren steht bei kein sbus Out! Denke nicht das sich das geändert hat müsstest also um Flashen ... Aber Versuch erstmal oben die 2 Einstellungen durch! Grade mit einem F3 bzw F7 FC ist es eigentlich einfach mit Fport weil man kein nicht invertiertes Signal abgreifen muss, nimmst also alles einfach vom Stecker!
      Gruß ausm Essiggurkenglas :D
    • Vielleicht habe ich dich falsch verstanden - hab mal ein paar Screenshots aus dem Video gemacht.

      Mirko nutzt in seinem Video den GND,+5V und den UART 4 Tx am FC. Und am R-XSR den GND,+5V und S.Port-Pin. Der S.BUS Pin ist der vierte am R-XSR und da ist bei ihm aber kein Kabel dran :)
      Bilder
      • Kakute F7 Pinbelegung.png

        557,59 kB, 903×477, 28 mal angesehen
      • R-XSR.png

        413,92 kB, 894×472, 26 mal angesehen
    • KampfGurke schrieb:

      Einfach mal mit diesen settings Rum spielen bzw nacheinander halt durch versuchen...

      serialrx_halfduplex = ON serialrx_inverted = ON

      Mal beides on je eins Off oder beide Off irgendwann geht's :)

      Hast aber das Sport Kabel an den TX Port vom UART gelötet nicht RX oder?

      Sbus geht mit der fport Firmware nicht, zumindest bei einer älteren steht bei kein sbus Out! Denke nicht das sich das geändert hat müsstest also um Flashen ... Aber Versuch erstmal oben die 2 Einstellungen durch! Grade mit einem F3 bzw F7 FC ist es eigentlich einfach mit Fport weil man kein nicht invertiertes Signal abgreifen muss, nimmst also alles einfach vom Stecker!
      Jo. Das S.Port-Kabel hängt am Tx-Port - sollte aber auch so sein oder?

      Wie gesagt, ich hatte nach deiner Empfehlung die F.Port-Firmware auf den R-XSR raufgezogen - getan hat sich danach leider auch nix. Werde deinen Vorschlag mit der Signalinvertierung mal testen :)