Betaflight stürzt bei zu viel Throttle ab

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Betaflight stürzt bei zu viel Throttle ab

      Guten Tag miteinander,

      stehe grad vor einem Problem, wo ich aktuell nicht mehr wirklich weiter weiß. Vielleicht hat ja jemand schon mal eine ähnliche Erfahrung gemacht.
      Hab meinen alten Copter in Teilen (also FC, ESC und RX )umgezogen auf einen neuen Frame. Alles soweit aufgebaut, im Garten ging der Testhover gut, allerdings beim ersten Punch-Out flippte er. Hab dann den selben Versuch nochmal gemacht, DVR aufgenommen, wieder geflippt, aber im DVR bezüglich OSD nichts auffälliges, also kein Restart. Habe dann den Copter auf der Werkbank eingespannt und mit Props nacheinnander alle Motoren hochlaufen lassen um festzustellen, dass es Motor 4, links vorne ist. Heute nach zwei Wochen nochmal den Motor auf der Werkbank getestet, über Betaflight den Motor hochgefahren und Problem leider immernoch vorhanden. Diesesmal hab ich aber festgestellt, dass sich der FC in irgendeiner Weise aufhängt. Ich kann im Configurator immer noch Tabs wechseln, aber die Einstellungen werden vom FC nicht geladen. Auch im Motortab steht die Balkenanzeige immernoch auf den 1600, bei denen der Motor aus ging. Auch wenn ich den Regler darunter bewege, bleibt die Anzeige bei ca. 1600 stehen.
      Hat jemand eine Idee? An der Spannungsversorgung kann es ja eigentlich nicht liegen, da er ja per USB angeschlossen war. Und er stürtzt eben nur an dem einen Motor ab.
      Versionen habe ich auch mehrere probiert, sowohl Betaflight, als auch BlHeli.
      Setup ist Fortini F4 OSD V2 (leider keine Blackbox) und Typhoon 32 V2, DShot hab ich auch schon mehere Versionen probiert.
      Als nächstes würde ich mal mit dem Osszi hin, allerdings stoppt der ESC so abrupt, dass es eigentlich sicher ist, dass das DShot Signal abbricht. Lötstellen sehen auch gut aus.

      Edit: CPU ist bei 3%

      Hatte jemand mal was ähnliches?
      LG
      Linus
    • Wenn der FC neu startet, tippe ich mal auf die Stromversorgung des selbigen.
      Hast Du Streifen im OSD? Sind die gasabhängig? - Ist das OSD stabil? Instabilitäten in der Spannungsversorgung sieht man oft im OSD.
      Hast Du eine LowESR Elko dran?
      Was hast Du am BEC des FC alles dran hängen? - Evtl ist der BEC überlastet und das Ding geht irgendwann in die Abschaltung.
    • Was genau passiert denn mit dem Motor 4
      Edit: äh, der esc stoppt. Hast du spaßeshalber mal n langsameres dshot oder multishot ausprobiert?
      Ausschließlich in der Mitte von Nix zu schweben macht mich depressiv!
      ...meine Rechtschreibprüfung funktioniert zum Glück nur bei kurzen Wörtern. Korrekte Wörter werden da immer durch unsinnige andere ersetzt.
    • Stefan73 schrieb:

      Wenn der FC neu startet, tippe ich mal auf die Stromversorgung des selbigen.
      Hast Du Streifen im OSD? Sind die gasabhängig? - Ist das OSD stabil? Instabilitäten in der Spannungsversorgung sieht man oft im OSD.
      Hast Du eine LowESR Elko dran?
      Was hast Du am BEC des FC alles dran hängen? - Evtl ist der BEC überlastet und das Ding geht irgendwann in die Abschaltung.
      Der FC startet nicht neu, er hängt sich auf. Ich muss die komplette Stromversorgung kappen, damit er neu bootet.
      Keine Streifen im Bild.
      Am BEC hängt nur die Cam und der RX.
      Nein, ich habe keinen Elko dran, hab ich bisher nie gebraucht und auf dem ESC sind auch echt einige drauf verbaut.


      Moon666 schrieb:

      Ich tippe mal auf einen Lötzinn Spritzer irgendwo, der unter lässt dann ausreicht für einen kurzen
      Ist ne Idee, ich werde mal unter der Lupe drüber gehen, ob ich irgendwo was sehe.

      simon.bethke schrieb:

      Was genau passiert denn mit dem Motor 4
      Edit: äh, der esc stoppt. Hast du spaßeshalber mal n langsameres dshot oder multishot ausprobiert?
      Multishot hab ich noch nicht ausprobiert, aber DShot 600 und DShot 1200. Werde dann mal noch das andere ausprobieren.
    • Also, hab nochmal die Kabel zum ESC neu verlötet. Also abgelötet, Lötpads sauber gemacht, altes Lötzinn entfernt und neu gelötet. Auf der Werkbank hat es jetzt getan, werde morgen mal testhovern.
      Finde ich trotzdem äußerst Dubios, dass wegen einer schlechten Lötstelle der DShot Leitung der FC abstürtzt... Kann mir das überhaupt nicht erklären, vorallem, war es ja auch unter 3.5, und dem alten BlHeli, also ohne Bidirectional DShot.