Airmode Betaflight 4.0, wie funktioniert die Landung

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Airmode Betaflight 4.0, wie funktioniert die Landung

      Hallo zusammen,

      habe mal eine vllt. blöde Frage. Der Airmode bei BF 4.0 stabilisiert den Copter mW ja mehr oder weniger in der letzten Position. Beim in der Hand halten reagiert das Teil nicht mehr auf die Gasstellung und regelt die Motoren selbstständig.
      Wie verhält sich das in der Praxis wenn ich landen möchte ?
      Bisher habe ich die Landepos angesteuert und dann entspr. Gas rausgenommen. Das scheint jetzt nicht mehr zu funktionieren da der Airmode dem entgegenwirkt, oder verstehe ich etwas faslch ?
      Habe das übrigens bisher noch nicht in der Praxis probiert!

      vg, Thomas
    • Maierchen schrieb:

      Copter in der Hand gehalten regeln die Motoren hoch obwohl Gasstellung auf Idle steht, das hat mich verwirrt und deshalb habe ich Airmode zunächst mal zur Sicherheit auf einen Schalter gelegt.
      Vorsicht: Der Copter sollte zwar mit Gasstick auf Idle bei Lageveränderungen ordentlich gegenregeln, jedoch sollte dabei die Motorendrehzahl sich nicht stetig erhöhen. Dies würde auf zu wenig Filterung hindeuten, was bei Betaflight 4.0.0 kein seltenes Phänomen ist.
    • FlyMac schrieb:

      Vorsicht: Der Copter sollte zwar mit Gasstick auf Idle bei Lageveränderungen ordentlich gegenregeln, jedoch sollte dabei die Motorendrehzahl sich nicht stetig erhöhen. Dies würde auf zu wenig Filterung hindeuten, was bei Betaflight 4.0.0 kein seltenes Phänomen ist.
      genau so verhält er sich was mich verunsichert hat. Deshalb habe ich den Airmode zunächst auf einen Schalter gelegt um beim Fliegen keine Überraschung zu erleben. Die Betaflight Einstellungen sind so wie geliefert, da habe ich nichts dran verstellt. Es ist übrigens die BG 4.0.3 aufgespielt.
      Wo muss ich denn ansetzen, welcher Wert muss geändert werden ?


      Dillbriese schrieb:

      Da ich mal annehme, dass er in der Hand keine Propeller drauf hatte, kann das gar nicht passieren und wird der völlig normale I windup sein.
      Propeller waren dran, ist ja nur ein kleiner XJB145.
    • @FlyMac entweder ich verstehe nicht was du meinst oder es ist falsch. Zu wenig Filter erhöht nicht die Drehzahl. Das macht höchstens zu viel P-term. (aber auch nur mit props in der Luft)
      Ausschließlich in der Mitte von Nix zu schweben macht mich depressiv!
      ...meine Rechtschreibprüfung funktioniert zum Glück nur bei kurzen Wörtern. Korrekte Wörter werden da immer durch unsinnige andere ersetzt.
    • simon.bethke schrieb:

      @FlyMac entweder ich verstehe nicht was du meinst oder es ist falsch. Zu wenig Filter erhöht nicht die Drehzahl. Das macht höchstens zu viel P-term. (aber auch nur mit props in der Luft)
      Betaflight 4.0.0 hatte die Tendenz zu Flyaways. Habe ich selbst bei einem meiner 3 Zöller erlebt als bei einem Prop etwa 1/3 eines Flügels abgebrochen war. Ohne Disarm hätte ich das Ding kaum runter bekommen.
      Bei einem 2 Zöller hatte ich etwas ähnliches: Mit Props und Airmode im Idle in der Hand gehalten und leicht geschüttelt. Die Drehzahl stieg automatisch innerhalb von etwa 2 Sekunden bis auf Vollgas an und nur ein Disarm half dagegen.
      Seit Betaflight 4.0.1, wo etwas mehr Filterung hinzugefügt wurde, hatte ich diese Probleme nicht mehr.

      Das Problem wird auch in den Release Notes erwähnt:
      • a number of users reported issues with their craft taking off with throttle at idle when running on Betaflight 4.0.0's default settings. It was identified that the default settings did not have enough filtering for setups with a lot of vibrations. More filtering was added to the defaults in 4.0.1. It is recommended that you upgrade directly to 4.0.1 or newer, to eliminate the risk of unintended flyaways introduced by this problem (#8043)
    • Maierchen schrieb:

      genau so verhält er sich was mich verunsichert hat. Deshalb habe ich den Airmode zunächst auf einen Schalter gelegt um beim Fliegen keine Überraschung zu erleben. Die Betaflight Einstellungen sind so wie geliefert, da habe ich nichts dran verstellt. Es ist übrigens die BG 4.0.3 aufgespielt.Wo muss ich denn ansetzen, welcher Wert muss geändert werden ?

      Ich fliege auch einen XJB-145, allerdings habe ich den Frame nach einem Crash gegen einen RaceX Mini von FPVFrame.ch getauscht. Der fliegt mit 4S 850mAh und BF 4.0.3 mit nahezu Stock-Settings super.

      Habe folgende Änderungen gemäss BF 4.0 Tuningguide gemacht:

      set iterm_relax_type = gyro
      set iterm_relax_cutoff = 11
      set i_pitch = 85
      set i_roll = 80
      set d_min_roll = 25
      set d_min_pitch = 28
      set d_min_boost_gain = 30
      set d_min_advance = 50
      set d_pitch = 38
      set d_roll = 30
      set tpa_rate = 50
      set tpa_breakpoint = 1500
      set tpa_mode = D
      set p_yaw = 35
      set i_yaw = 100
      set d_yaw = 0
      set f_yaw = 35
      set iterm_rotation = OFF


      Dazu dann noch die Filtereinstellungen für 3" aus den Community Presets:

      set gyro_lowpass_type = BiQUAD
      set dyn_notch_min_hz = 150
      set dyn_lpf_gyro_min_hz = 150
      set dyn_lpf_gyro_max_hz = 650
      set dyn_lpf_dterm_min_hz = 150
      set dyn_lpf_dterm_max_hz = 250
      set dterm_lowpass_type = BiQUAD
      set dterm_lowpass2_hz = 150
    • gerade nochmal getestet ...
      Airmode on, Gas Idle: Props regeln schnell auf Lageänderungen und die Drehzahl geht immer wieder auf Idle
      Einmal Gas und wieder auf Idle: Motoren drehen langsam immer höher und auf Gasstick keine Reaktion mehr

      Edit: oh da haben sich unsere Beiträge überschnitten. Bin jetzt beschäftigt, werde mir die Sache heute Abend mal genau ansehen. Bei den oberen Werten sind bei mir einige Abweichungen, die unteren sind bei mir bis auf dyn_lpf_gyro_max_hz = 450 identisch.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Maierchen ()

    • Maierchen schrieb:

      gerade nochmal getestet ...
      Airmode on, Gas Idle: Props regeln schnell auf Lageänderungen und die Drehzahl geht immer wieder auf Idle
      Einmal Gas und wieder auf Idle: Motoren drehen langsam immer höher und auf Gasstick keine Reaktion mehr

      Edit: oh da haben sich unsere Beiträge überschnitten. Bin jetzt beschäftigt, werde mir die Sache heute Abend mal genau ansehen. Bei den oberen Werten sind bei mir einige Abweichungen, die unteren sind bei mir bis auf dyn_lpf_gyro_max_hz = 450 identisch.
      Die oberen Settings sind die offiziellen Empfehlungen für Freestyle. Vorwiegend etwas mehr I und Dmin sowie Iterm-Relax auf Gyro mit einem Cutoff von 11. Hat sich bei mir so bewährt, fliegt sich etwas smoother als das racelastige Grundsetup.
      Die Filtereinstellungen entsprechen grundsätzlich dem Stocksetup, einzig die obere Grenze für den dynamischen Low Pass Gyro Filter wurde für die schnelldrehenden 1407 3600KV Motoren etwas erhöht (set dyn_lpf_gyro_max_hz = 650).
    • Mit ein bisschen Übung kann man so 10cm über dem Boden schweben und disarmen. Das bisschen fallen macht dem nichts aus.
      Hilfreich dabei ist es, auf etwas zuzufliegen, so kann man die Höhe und vertikale Geschwindigkeit einschätzen, auch wenn man den Boden (wegen Kameraneigung) nicht sieht. Dieser Gegenstand sollte nichts wertvolles (besonders kein Mensch) sein. Büsche/Bäume/Sträucher sind ganz gut.
    • habe die Settings mal eingespielt, allerdings ohne Verbesserung der Ausgangsituation.
      Damit Ihr das mal selber sehen könnt habe ich ein kurzes Video gemacht. Bei Serk. 9-10 kurz Gas gegeben, ab dem Moment drehen die Motoren automatisch hoch obwohl der Gasstick in Idle steht. Auf Gasänderungen reagiert der FC auch nicht mehr.
      Das gleiche mal probiert mit Roll, da geht alles wieder in Ruhe.

      Youtube Video: