HOW TO: Vernünftige WS2812-Beleuchtung am Copter

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • HOW TO: Vernünftige WS2812-Beleuchtung am Copter

      (Keine Ahnung ob das hier richtig ist, mir viel aber nix passenderes ein. Ein Build Log ist es ja nicht wirklich. Wenn falsch, bitte bescheid sagen. :) )

      Kein großes Palaver, straight to the point:
      LED-Beleuchtung am Copter ist cool.
      Noch cooler ist sie, wenn sie nicht nur leuchtet, sondern auch die Farbe wechselt etc. Als Kiss-User ist man da leider sehr eingeschränkt. Betaflight bietet zwar einige Optionen, aber auch das ist mir zu wenig. Eine neue Idee muss her. Durch Zufall habe ich mich bereits vor einigen Monaten mit Arduinos und WS2812-LEDs auseinandergesetzt.

      Meine Damen und Herren, ich präsentiere:
      Meine WS2812-Beleuchtung!

      Ich nutze einen DFRobot Beetle sowie 4 WS2812 LED Strips (die kommen zwar noch mit so einer Steuerplatine, die wird aber nicht benötigt.)

      Die Konstruktion ist denkbar simpel, der Beetle bekommt 5v, vom Beetle gehen dann Spannung, Masse und Signal auf die LEDs.
      Konkret möchte ich damit den ersten Police-Sica konstruieren, mit 6 LEDs pro Arm.
      Das sieht dann in etwa so aus:


      Und obwohl der Beetle schon echt klein ist, ist er mit 20x22mm noch immer zu groß für einen 20x20 Stack.
      Daher habe ich mich an Fusion gesetzt, und einen kleinen Mount gezeichnet, welcher hier zu finden ist.

      Aktuell ist mein Drucker noch sehr beschäftigt, aber sobald er fertig ist, kann ich den Mount auch mal drucken. Der ist nämlich noch nur auf dem Papier gut.
      Des weiteren bekommt der Sica noch Halterungen an die Arme, um Kurzschlüsse zu vermeiden. Die entsprechenden Dateien findet man hier.

      Bei Fragen, Anregungen, etc... immer raus damit! :thumbsup:
      MfG, Elias

      Alle Angaben ohne Gewähr
      ;)

      maggo schrieb:

      Diese Erfahrungen und Entdeckungen die man macht aus irgendner Scheiße was fliegendes hinzubekommen - unbeschreiblich.
    • @mnieh Ich hätte eine frage zu den LED vom Typ WS2812B , vielleicht fällt dir hierzu etwas ein:

      Ich hatte mir auch ein paar Streifen von den LED´s geholt bevor REDBEE dicht macht, wollte die eigentlich ohne Arduino Basis direkt an den FC anschließen, hat aber irgendwie nicht funktioniert.... also haben gar nicht geleuchtet.
      Habe die Tage nochmal ein wenig gegoogelt um herauszufinden woran das liegt. Jetzt habe ich in anderen Foren gelesen das bei den LED strips ein 300Ohm Widerstand an den Input gelötet werden soll, und ein Kondensator an +/-, allerdings nur in Verbindung mit einer Arduino Hardware/Software.
      Da du dich schon einmal mit den dingern beschäftigt hattest kannst du das bestätigen ? Egal ob jetzt mit Arduino oder ohne.

      Danke schonmal!
    • Hi @Schasch
      der Widerstand ist dafür da, um zu verhindern, dasdie LEDs bei ausgeschalteter Stromversorgung durch eventuelle Signale gekillt werden. Das selbe gilt für kurzzeitige Spannungsspitzen beim einschalten, diese können ebenfalls eventuell entstehen und wären dann logischerweise auch nicht das Gelbe vom Ei. Im Zweifelsfall wäre dann aber nur die Erste, dem Anschluss am nähesten liegende LED kaputt, nicht alle - mir persönlich ist das einlöten von Widerständen zu doof, ich lass es weg und hoffe auf das beste. :D

      Zu deinem Problem; hast du die LEDs in deiner Software richtig konfiguriert? Was für ein FC ist es, was für Strips? Mach doch mal ein Foto von der Verkabelung :)
      MfG, Elias

      Alle Angaben ohne Gewähr
      ;)

      maggo schrieb:

      Diese Erfahrungen und Entdeckungen die man macht aus irgendner Scheiße was fliegendes hinzubekommen - unbeschreiblich.
    • FC: HGLRC F440 Micro Stack + 40A 4in1 + F4 Flight Controller
      LED: WS2812B Platien flexibel - 5050 SMD LED IP65
      Konfiguriert habe ich sie in Betaflight LED 0-12 aber siehst auf dem bild. Ich hatte es wieder abgelötet und jetzt kurz nochmal angeschlossen zum fotos machen, also sehen die löt punkte nicht schön aus :D . Habe die Verbindung mit dem Multimeter gemessen sieht alles gut aus.
    • Ich hab 5,28V anliegen. Ist wahrscheinlich zu viel nehme ich an. Externe 5V müsste ich mal schauen wo ich die her bekomme.
      Werd ich morgen versuchen.

      edit: Habe noch ein Netzteil gefunden mit 5V spannung, probiere ich nach der Arbeit. Habe mir jetzt aber zusätzlich auch so ein Beetle geholt, von den Möglichkeiten her sieht das sehr interessant aus.
      Und das bisschen Programmieren sollte auch noch machbar sein ;).
      Du hattest den Robot quasi an die 5V und ground deines FC ranngehängt nehme ich an. Hattest du den COpter schon in der Luft ? Wie sieht es mit dem Stromverbrauch aus merkst du da einen großen unterschied?

      edit2: habe nochmal externe Spannung angelegt da rührt sich gar nichts :(. Naja ich warte auf den Beetle und probiere es damit.

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Schasch ()

    • Ups, hab deine Edits nicht gesehen, sorry dafür.
      Nein, der Copter war noch nicht in der Luft, der ist auch allgemein noch nicht fertig.

      Aber deiner sieht scharf aus! Hast du den Beetle mit dem 20x20 Mount befestigt?
      MfG, Elias

      Alle Angaben ohne Gewähr
      ;)

      maggo schrieb:

      Diese Erfahrungen und Entdeckungen die man macht aus irgendner Scheiße was fliegendes hinzubekommen - unbeschreiblich.
    • Ist nett Danke, aber ich glaube ich lasse es momentan einfach mal so lose drinnen. Zum fliegen bin ich mit dem noch nicht gekommen aber ich vermute das es keine Probleme gibt wenn das ding locker drinnen ist.
      Ich bin mir grad nicht sicher aber ich glaube stack mäßig wäre es bei dem build eh nur über dem VTX möglich, die anderen Positionen sind schon voll ....... die Runcam Split 2 braucht einfach zu viel platz :D