Kopter kippt auf Pitch/Roll bei scharfen Kurven - PIDs?

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Kopter kippt auf Pitch/Roll bei scharfen Kurven - PIDs?

      Hallo Zusammen!

      Kleines Problem... keinen direkten Lösungsansatz.. bzw. die Erfahrung dafür..

      Ich hab mir nen 3 Zöller zusammengebaut, zuerst auf INAV geflogen. Lief soweit gut und ohne Probleme. Nur war es immer so, dass der Kopter bei scharfen Wendungen (also bspw ein 180 Grad Turn bei etwas Geschwindigkeit) immer in der Luft um 90 Grad umkippte. Er fängt sich danach und richtet sich wieder auf, sodass ich weiterfliegen kann aber Stabilität ist was anderes.

      Nun fehlt mir noch die Tiefe mit den PIDs, bzw. dem Auslesen der Blackbox, sodass ich selbst auf diese sehr detaillierte Fehlersuche gehen kann. Ich habe danach nun und aktuell BF 4.1 geflasht weil ich eben im Probieren der PID-Einstellungen (Habe die D- und auch I- Werte vermutet) nicht wirklich weitergekommen bin. De facto tut er nun genau das Gleiche auch mit Betaflight-> er kippt in starken Kurven.. wohl im eigenen Propwash. Er Oszilliert nicht, fliegt eigentlich sonst sehr sauber, kippt eben nur in Kurven.

      Ich habe einen Blackbox log der zwar noch auf INAV gelaufen ist, doch ist das Problem ja trotzdem das gleiche wie jetzt in BF. Dazu habe ich auch ein Videobeispiel vom DVR der Brille. Auf dem Blackbox log konnte ich sehen, dass Motor 3 in der Kurve viel stärker angesteuert wird als die übrigen.. was ihn eben kippen lässt.

      Gibt es hier jemanden der mir hier vllt. mit sehr geschultem Blick sagen kann was falsch läuft? Ich vermute Filter oder eben PIDs.. aber ich selbst kann in diesem Dschungel eben nicht erkennen was ich wonach beurteilen oder sogar an Einstelungen ändern muss um es zu beheben.

      Wenn sich einer der Sache annimmt, kann ich gerne die Blackbox Text datei hochladen und sagen an welcher Stelle das Kippen stattfindet. Ich kanns nur gerade nicht hochladen, weil ich noch nicht zu hause bin.

      Besten Gruß
    • Hi,

      ein Video und Blackbox-Log sagen meist mehr, als jeder Fehlerbeschreibung. Daher am besten das Video kurz auf Youtube hochladen, den BB-Log kann man hier direkt als Anhang hochladen.

      Grundsätzlich kann ich sagen, dass die meisten Quads mit Stock-PIDs relativ zuverlässig fliegen. Bei 3" muss man zwar optimieren aber grundsätzlich flugtauglich sollten die Teile auch so sein. Meist "verschlimmbessert" man nur wenn man an PIDs dreht ohne wirklich zu wissen, woher das Problem tatsächlich kommt.

      Fliegst du im stable oder Acro mode? Ich tippe mal auf "stable" da du von Stabilisierung sprichst. Ich habe es schon erlebt, dass die Komponenten auf den FCs so schlecht waren, dass an ein vernünftiges Fliegen im Stable-Mode nicht zu denken war, vielleicht liegt bei dir das Problem ebenfalls an problematischer Hardware.

      Video und BB-Log werden sicher helfen.
    • Servus!
      Leider sind die Möglichkeiten softwareseitig genauso vielfältig wie hardwareseitig - deshalb sind ein paar mehr Infos wie "ich hab nen 3"... " nach wie vor unerlässlich wenn das hier kein seitenlanges Rätselraten werden soll.

      Ein Foto kann auch manchmal helfen....

      Gruß Chris
      Ihr seid neu hier? Hier könnt ihr euch vorstellen :
      Klick : Vorstellungsrunde
    • Oh hey, vielen Dank für die schnelle Antwort.

      Ich fliege ausschließlich im Acro Modus. Ich gebe euch Informationen.. alle die ihr braucht.. auch den Blackbox log bzw. das video, nur eben heute abend wenn ich zu hause bin.

      Mein Setup schonmal vorweg:

      Rahmen: Flyfox NO.11 135 mm
      ESC: 30a 2-4s Blheli Shot600, Multishot, Oneshot 4 in 1 ESC
      FC: Kakute F7 Mini mit BF 4.1 bzw. vorher INAV 2.1 (mit Softmount)
      Motoren: EMAX 1306b 4000KV
      Propeller: 3 Zoll, 2-Blatt Gemfan 3025
      VTX: AKK FX 3
      Cam: Runcam Split Mini V2
      GPS+Kompass: Matek M8Q 5883
      Receiver: R9MM über F.Port
    • Der Log File ist 9 mb groß gepackt... hier sind max 1 mb erlaubt..

      Der Flug dauert 5:35 min und ich wusste jetzt nicht wie ich es rausschneide, daher hab ich es in Dropbox hochgeladen.

      dropbox.com/sh/l0u86z8t06gjp4w…tEI4H28sOjsk3V8FiFna?dl=0

      Zur Blackbox:
      • Ab Sek 00:38.623 leite ich die Rechtskurve ein. Ab 00:39.191 schaltet Motor 4 komplett ab, während Motor 3 von allen die meiste Leistung bringt. Generell liegt die Leistung von Motor 3 immer etwas höher als die der anderen, kann aber natürlich auch mit dem Schwerpunkt oder anderen Umständen zusammenhängen. Das Kippen kommt aber wohl dann vermutlich durch das abschalten eines Motors, in diesem Falle Motor 4...
      • Das Gleiche Spielchen ab 00:50.053 in einer Linkskurve. Hier Schaltet Motor 2 komplett ab und der Kopter kippt.
      • Dann ab 01:08.968 wieder eine Rechtskurve mit abgeschaltetem Motor 4
      • 04:45.495 auch hier kann man wunderbar sehen wie er nach dem abschalten abkippt
      ...hach ja.. wundervoll so ne Blackbox.. wenn man sie lesen könnte :/

      Generell scheint mir aber das Problem in der Abschaltung eines Motors zu liegen? Kann es mit einer zu niedrigen Throttle-Einstellung im ESC zusammenhängen? Der Copter läuft übrigens auf DSHOT600

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von Ruhr ()