Motoren rauchen?!? Isolierung verbrannt!

    • Motoren rauchen?!? Isolierung verbrannt!

      Hi,

      heute das erste mal geflogen, beim ersten Flug war alles gut. Es hat danach schon etwas angebrannt gerochen aber ich habe mir nach einem kurzen Check keine weiteren Gedanken gemacht. Beim zweiten Flug habe ich irgendwann gemerkt das meine Motoren rauchen, bin dann sofort gelandet und habe sofort den Stecker gezogen. Mir ist direkt aufgefallen das bei sogut wie jedem Motor die Isolierung(Spule) schwarz ist. Ich vermute mal die sind fast kaputt :( war wie gesagt das erste mal das ich überhaupt geflogen bin außerhalb des Simulators. Woran könnte das liegen? Mir ist in Betaflight beim Motorentest bereits aufgefallen das die Drehzahl sich bereits bei 60% des Maximums extrem ungesund anhört, dachte aber das liegt an den fehlenden Propellern. Kann es es sein das das Quad eine zu hohe Drehzahl hat?? Die Motoren sind extrem heiß, man verbrennt sich die Finger daran :S Wäre nett wenn mir jemand helfen könnte bin absolut neu in der Materie...

      Quad: GEPRC CROC7
      Akku 6s
    • Da schließe ich mich 100% an, vorausgesetzt es wurden keine anderen Motoren verbaut.

      1) Das Quad mechanisch noch mal komplett überprüfen. Sind alle Schrauben fest? Ist der FC fest? Kann irgendwas vibrieren? Liegt etwas am FC/Gyro an?

      2) Wie sehen die PID Werte aus? Was wurde dort ggf. verändert?

      3) Wie sehen die Filter aus? Wurde dort etwas verändert?

      4) Wahrscheinlich nicht, aber war die Blackbox eingerichtet und gibt es ein Log?
    • Yamie hat recht es sind GR2306 1600KV Motoren verbaut. Was sagt ihr zu den eingestellten Werten? Habe da bis jetzt noch nichts verändert, müssten also default Werte sein. FC und rest ist alles fest verschraubt, Gyroskop funktioniert einwandfrei. Blackbox und Log wird nehme ich an auf sd gespeichert? Hätte ich in dem Fall leider nicht. Im anhang habe ich für euch die entsprechenden Werte.
      Bilder
      • Screenshot (27).png

        269,96 kB, 1.945×1.049, 27 mal angesehen
      • Screenshot (28).png

        369,66 kB, 1.948×1.049, 15 mal angesehen
      • Screenshot (29).png

        280,22 kB, 1.950×1.049, 19 mal angesehen
    • Es scheint so, als würde der mit Stock PIDs ausgeliefert : /
      War das ein Kit oder kam der gebaut?

      Mototschrauben, wie @Stefan73 sagt wäre eine Möglichkeit, aber bei einem Kit/Fertigcopter würde ich erstmal vermuten wollen, dass es an was anderem liegt.

      Aber an den Settings können wir einiges ändern/verbessern.
      Die Filter und die PIDs sollten natürlich richtig eingestellt sein, aber ohne Logs kann ich dir dazu erstmal nicht soviel sagen, die darfst du aber gerne nachreichen :)
      Dann bitte in 2k mit Debug: Gyro_Scaled

      Auf den RPM Filter solltest du aber nicht verzichten.

      Dafür bitte im Configurations Tab diese Einstellungen vornehmen:



      Wenn der Schalter bei Bidirectional DShot nicht bleibt, dann müsstest du noch die ESCs flashen, aber falls das so ist, bitte vorher nochmal melden :)
      Nicht das dabei was schiefgeht!

      Wenn das getan ist noch bei den Filtern unter PID Tuning diese Einstellungen vornehmen:


      Falls du genauer wissen möchtest was was ist erkläre ich das gerne mal, aber erstmal wäre es gut einfach die Einstellungen zu übernehmen :)

      Zuguter Letzt kannst du bei den PIDs selber noch diese Einstellungen ändern:


      Den Advance brauchst du nicht und den Gain kannst du aufrunden.

      Heiße Motoren bedeutet, wenn mechanisch am Copter nix falsch ist, in der Regel falsche Filter oder zuviel D.
      Bitte einfach auf Verdacht mal den Master Multiplier auf 0,8 stellen, das senkt schon mal allgemein die PIDs und dann noch den PD Balance auf 1,2 setzten, das reduziert deinen D etwas.

      Wenn die Motoren dann bei den aktuellen Temperaturen immer noch heiß werden stimmt da eindeutig was am Copter nicht.
      Aber bitte auch mal ein paar Logs einreichen, dass wir Filter und PIDs genauer einstellen können.

      Fliegen ohne sich zu verbrennen sollte der so aber eigentlich schon.


      Wenn du sowas machst, immer erstmal etwas auf der Stelle schweben, dann landen, fühlen wie heiß die Motoren sind.
      Sind sie so heiß, dass du sie nicht festhalten kannst, dann sind sie zu heiß, dann nicht fliegen und erstmal den Fehler suchen.
      Wenn sie nicht zu heiß sind einen kurzen Testflug, so etwa 30 Sek. mit ein paar Vollgasschüben, dann nochmal die Temperatur überprüfen.
      Wenn dann auch alles ok ist kannst du weiter fliegen :)
    • danke für die ausführliche Hilfe, ich werde das morgen alles einmal so einstellen und erneut testen, da mein FC allerdings kein Sd slot besitzt wird es schwierig morgen mitzuloggen. Auf meiner FC Anleitung steht: DSHOT 1200,600 300 allerdings nicht. Kannst du mir sagen was die Settings bedeuten? Habe ebenfalls vergessen zu sagen das ich mein Motor Leerlauf Gas Wert (Arming) auf 0.01 heruntersetzten musste da das Quad beim defaultwert 5.5% bereits abgehoben ist, mein jetziges DSHOT Protokoll ist das 600er falls das von Bedeutung sein sollte. Aber ich stelle das jetzt mal alles so ein und versuch es morgen nochmal, werde dann vom Ergebnis berichten.
    • Hab mir grade den FC mal angesehen und konnte leider auch keinen Flashspeicher auf dem Board erkennen.
      Du kannst mal schauen welche Optionen der dir in der Blackbox als Speicher anbietet, wenn da aber kein Onboardflash ist, dann sieht es mit Loggen tatsächlich erstmal schlecht aus :/
      Falls du doch daran interessiert bist kann ich den OpenLager empfehlen: store.myairbot.com/openlager.html
      Der käme auf einen freien UART und kann dann auf eine SD Karte loggen, ist aber erstmal nicht so wichtig.

      Das DShot 300 nicht in der Liste steht ist nicht wichtig, 300 kann der :)
      Meist wird nur das höchst mögliche DShot Protokoll angegeben.
      Aber wir gehen auf 300, weil für Bidirectionale Kommunikation DShot300 bei einer F4 MCU das machbare Maximum ist.
      Allerdings ist der Vorteil von DShot600 eh minimalst. Bei DShot300 nutzt man dann auch nur 4k Gyro und 4k PIDloop, denn mehr bringt dann auch nix.
      Die meisten F7 MCUs schaffen 8k/8k mit DShot600, aber einen Unterschied spürst du da dann trotzdem eher nicht : /

      Wenn der Copter schon bei 5% Gas abhob stimmt was bei den PIDs/Filtern gar nicht, das sollte der nämlich nicht schaffen ;)
      Ich schätze mal, das bei dem Copter der Schwebepunkt so bei 25-35% Gas liegt, bisschen vom Prop und LiPo abhängig.

      Aber die Filter und PIDs gehen wir ja jetzt an :)
    • Habe soweit alles eingestellt(außer ESC Sensor Regler)-> der ging nicht. Habe 2 Testflüge unternommen. Während des ersten Hauptsächlich schweben und kurze schlagartige Sprünge um die Motoren voll zu belasten. Während des zweiten Fluges habe ich einen längeren Flug unternommen ca 500m immer wieder hin und zurück. Hat echt Spaß gemacht, war das erste mal das ich meine FPV Brille Tatsächlich benutzt habe. Bei jedem Testversuch habe ich die Motoren angefasst und sie waren nicht heiß. Die Einstellungen scheinen geholfen zu haben, zwar hatte ich einige Abbrüche, die mir auf dem OSD als 4 Sterne Fehlermeldung angezeigt wurden und das Quad konnte in manchen Positionen nicht gearmt werden(komisch da arming Winkel 180) aber alles in allem bin ich zufrieden. Kannst du mir vlt noch etwas genauer erklären was du dort verändert hast, bzw. mir helfen die Ursache des ursprünglichen Problems zu identifizieren?
    • Ah sorry, ja ESC Sensor Regler ist auch nicht so wichtig, das ist ESC Telemetry, wird nicht von jedem unterstützt.

      Was du jetzt beschreibst klingt gut und besonders schön, dass es dir Spaß macht, so soll das :D

      4 Sterne Fehlermeldung klingt komisch, vielleicht zeigst du mal deine OSD Settings, wäre gut zu wissen was es ist. Was genau meinst du mit Abbrüchen?
      RX Loss oder Video weg?
      RX Loss wäre Funke zum Copter, dann würdest du wohl abstürzen :)
      Video weg liegt an allem, VTX, Empfänger Modul, Antennen, Sendeleistung, Brille, Quad Ausrichtung, Bäumen usw......

      Das der Copter nicht armen kann, kann viele Ursachen haben, die meisten sollten dir im OSD angezeigt werden, hast du PreArm?


      Und klar die Settings:

      DShot300 und 4k/4k + Bidirectional ist nur dafür da, damit der RPM Filter funktioniert.
      Die Filter entfernen den Lärm von den Gyrodaten, damit der FC genauer weiß was grade passiert.
      Der RPM Filter kann ganz gezielt auf bestimmten Frequenzen abhängig von der Motordrehzahl filtern, weil die ESCs dem FC dann mitteilen können wie schnell die Motoren grade drehen.
      Ich kann nachher mal ein paar Bilder dazu raussuchen und das daran noch erläutern.

      Dann zu den Filtern direkt, 3 Harmonics bedeutet, dass 3 Frequenzbänder vom RPM Filter gefiltert werden können, das zeige ich später mal auf dem Bild :)

      100mhz Min bedeutet nur, dass der nicht darunter geht, ist nicht nötig denn so niederfrequenter Lärm wird meist eh ignoriert, das Gyro hat auch einen internen Hardware Filter der quasi alles unter 150mhz entfernt.

      Der Dynamic Notch filter funktioniert mit dem RPM im Tandem, ohne RPM rät der quasi wo sich die Motoren befinden, aber mit RPM wird der noch effektiver.
      Der legt immer wieder statische Notchfilter über die ermittelten Frequenzen, diese Form der Filter erzeugt nur sehr wenig Latenz, was für die Performance von deinem Cotper relevant ist. Desto weniger Latenz umso besser fliegt der sich :)

      Dann haben wir vorsorglich die PIDs allgemein reduziert um weitere Schäden an den Motoren zu verhindern, wenn jetzt erstmal alles gut ist und du das Gefühl bekommst der Copter ist zu träge kannst du den Master langsam erhöhen. Der ist etwas abhängig von Power/Masse Verhältnis, also desto größer das ist umso kleiner kann der Master sein. Hängt aber auch stark von der Größe des Copters ab :)

      Dann haben wir das P/D Verhältnis zu Gunsten von P verändert. Ein hoher D Wert führt schneller zu heißen Motoren.
      P leitet die Bewegung ein und D dämpft diese dann ab, also wirkt dem entgegen. Wenn D zu hoch ist führt das zu einer stark gedämpften Bewegung und irgendwann zu Oszillationen und einer großen Last auf den Motoren.
      Ist P zu hoch hast du erstmal ein starkes Bounceback nach einem Flip oder Roll.
      Also weniger D war zum Schutz der Motoren :)

      Dann noch der D_Min Gain und Advance.
      D_Min ist der Minimal D Wert der immer dann aktiv ist, wenn der Copter grade keine starken Änderungen durchführt. Wenn du dann ein hartes Manöver fliegst wird der D Wert vom D_Min aus gesteigert bis er am D bzw D_Max ankommt. Halt um eine starke Bewegung abfedern zu können.
      Der Gain und der Advance sind dabei beides Faktoren die den D Wert steigern. Wobei der Gain abhängig vom PID Error also der Abweichung vom Soll(Setpoint) zum Ist(Gyro) ist und Advance ist nur Abhängig vom Setpoint, also setzt dieser Früher ein und steigert den D schon bevor der Copter in der Reaktion ist. In den meisten Fällen sind unsere Copter aber nicht so träge, dass wir einen Advance brauchen, oder unser D_Min ist nicht so niedrig und weit vom D_Max entfernt das es viel Sinn macht zumal wir zu Anfang eines Manövers auch noch den Feedforward haben der für den P das ist, was der Advance zum Gain ist.
      Wenn wir den Advance entfernen können wir den Gain einfach etwas aufrunden. Das spielt aber keine große Rolle.
      Letzten Endes führt das dazu, dass wir länger auf dem niedrigeren D Wert bleiben, was wiederum die Motoren schonen soll.


      Das ist jetzt alles nur kurz angerissen und um alles zu verstehen muss man sich sehr intensiv in den PID Loop und die Filter Dynamic einarbeiten. Aber ich hoffe du bekommst eine leichte Vorstellung von dem was wir gemacht haben :)
    • jaa so ungefähr :D ich merke schon da habe ich noch einiges an Materie vor mir, du würdest mir also raten die Settings ersteinmal so zu lassen? Ich habe bemerkt das der Motor vorne links wesentlich mehr Geräusche produziert als die anderen. habe den jetzt mal gecheckt und der dreht sich nicht wirklich flüssig wie die anderen. Es ist außerdem der Motor bei dem am meisten Spulenisolierung verkohlt ist. Beim Flug vorhin lag das Quad aber trotzdem relativ stabil in der Luft. Ich vermute den hat es erwischt, würdest du riskieren weiter mit dem zu fliegen? Ich denke das sich durch den erhöhten Reibungswiederstand und die erhöhte Vibration der Verschleiß weiter fortsetzen wird, bis der irgendwann ganz den Geist aufgibt.... aber ich als Anfänger kann das nicht wirklich beurteilen :whistling:


      PS: 4 Sterne bedeutet visueller Alarm, was auch immrr das heißen soll... nach ner Weile ist das meistens verschwunden?! Werde die Tage mal versuchen herauszufinden was er denn da hat..

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Ockerle ()

    • Motoren geben immer irgendwann den Geist auf.
      Hab mir mal in nem Race das Lager komplett verglüht, weil ich zu Ende fliegen musste aber auf einem 3Blade Prop vorne links nur noch 2 drauf hatte xD
      Sowas passiert, da konnte ich die Lager tauschen.

      Die Option hast du auch, wenn es Geräusche macht ist es wohl das Lager, die Isolierung ist nicht schön, aber solange der Motor noch läuft nicht so wichtig.

      Ich denke flieg erstmal noch was damit, wenn es fieß wird schau mal, dass du da das lager getauscht bekommst. Und dann im Sommer ist ein neuer Satz Motoren dran.
      Meine Wahl wäre dann wohl diese hier in 2307 1800KV: eu.amaxshop.com/?product=1103-…207-5-2305-2306-2307-2308
      Bei 22€ / Stück aus De wirklich gut.
    • So hier mal noch mit einem Bild zu den Filtern :)



      Links sind Roll, Pitch und Yaw ungefiltert.
      Und rechts daneben sind sie hochskaliert.
      Bei dem Pitch habe ich mal was angestrichen.
      In Rot siehst du 3 Frequenzbänder vom Motor bzw der Drehzahl, wobei das Unterste das eigentliche Band ist und die anderen 2 sind Echos oder Harmonics ;)
      Deswegen macht es in 90% der Fälle Sinn, die Harmonics auf 3 zu lassen, mehr braucht man eigentlich nicht, denn mehr habe ich noch nie gesehen.
      Und um nur eine Harmonic zu filtern muss der Copter extrem sauber sein, habe ich auch noch nicht gesehen.
      Dann in Gelb angestrichen sieht man noch ein Band auf ca 120Hz das ist Frameresonanz, die kann man zB manuel mit einem statischen Notch Filter rausfiltern.
    • Ockerle schrieb:

      müsste ich dann die Settings wieder abändern? Da ja 1800KV mehr RPM bei gleicher Leistung hat wie die 1600er die ich momentan habe? Oder spielt das keine Rolle?

      KV ist nicht gleichbedeutend mit Leistung!

      Der Motor hat aber sehr wahrscheinlich gute 30-50% mehr Leistung als deine jetztigen.
      Die Leistung ist nicht abhängig von der KV, aber wie viel der Leistung genutzt werden kann schon.

      zB. Du hast einen 500W Motor und wir nehmen mal an, der LiPo begrenzt den nicht, was in de Realität fast immer der Fall sein wird.
      Und der Motor hat 1500KV für 6S.
      Und erreicht trotz seines Props seine "maximale" Drehzahl, aber braucht dafür nur eine Leistung von 400W.
      Dann kannst du um auf die 500W zu kommen die möglich sind entweder einen größeren oder schwerere Prop also mehr Pitch nutzen, der bei gleicher Drehzahl mehr Leistung nutzt.
      Alternativ könntest du einen Motor mit vielleicht 1750KV nehmen, der erreicht dann mit dem selben Prop wohl schon seine 500W.

      Da die Leistung aber meist von dem LiPo begrenzt wird macht das in der Realität nicht so einen großen Unterschied.
      Im extremen Fall kannst du aber Throttleresolution verlieren.
      Und wenn du eine hohe KV an hoher Spannung fliegst, sinkt zwar die Reaktionszeit vom Motor, also der dreht schneller an, aber dafür steigt auch die Last, also der dafür nötige Strom.
      Das führt wieder zu mehr Wärme und einer schlechteren Effizienz. Ist außerdem schwieriger zu tunen ;)

      Ich fliege 2308 2200KV an 6s und 2306 2300KV auch an 6S. Beschleunigung ist nicht vergleichbar mit zB. 2700KV an 4S, aber Effizienz ist halt kacke :P
      Und ich habe einen 2" mit 1106 6300KV an 4S, da glühen dann die Motoren ;)
      Macht aber mehr Spaß als alles andere, für ca. 90s....