XM+ an Betafpv F411 AiO läuft nicht

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Mahlzeit
      Ich bin etwas ratlos.
      Ich habe seit ewigkeiten mal wieder ein neues Quad aufgebaut.
      Verbaut ist ein BetaFPV AIO F4 12A, mit Eachine 0803 Motoren und Frsky XM+
      Der Xm ist mit der Funke gebunden und leuchtet dauerhaft grün. Auf dem Board ist der XM+ an 5V, G und SBUS angelötet. In Betaflight ist unter ANSCHLÜSSE UART2 serieller Empfänger angewählt, bei KONFIGURATION "serieller Empfänger" und "SBUS"
      und bei EMPFÄNGER Kanalzuordnung FRSKY gewählt.
      Leider tut sich im Empfängertab gar nichts!
      Hab jetzt auch auf die neueste Firmware geflasht.
      Wo könnte der Fehler liegen?
      Der XM+ funktionierte in einem anderen Kopter einwandfrei
      CLT140, Piko BLX, LittleBee 20A, RCX1407-5000KV, Foxeer Micro, XM+
      E-Flite X-Vert Vtol, Unify, Foxeer Micro, SpektrumAIO
      KK90GT, PikoBLX, Cicada 10A, Aokfly 1104 7200KV, Caddx EOS2, XM+
      Toothpick mit Caddx EOS, AIO-FC, Happymodel 0703 19000KV, VTX03
      Mobula7 HD
      Schnatti ^^
      FrSky X-Lite
      Jugendliche, rechts und links 2000 Volt und oben brennt keine Lampe! :P :P

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von werderfuchs ()

    • Ich meine SBUS ist UART1, nicht UART2 bei dem Board.
      SBUS ist soweit ich weiß einfach RX1 jedoch mit Inverter. Ich würde also Mal UART1 als seriellen Empfänger im Ports-Tab wählen und falls etwas an TX1 RX1 angelötet ist, dies auf einen anderen UART legen um einen Konflikt zu vermeiden.

      EDIT: Wahrscheinlich falsch, habe wohl auf den falschen FC geschaut.

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Hazzahfpv ()

    • Im Manual steht uart2. Aber uart1 habe ich auch schon probiert. Es ist bis auf die Motoren noch nichts angelötet. Sbus inverted on hab ich auch schon versucht.
      Kann man den XM+ auch woanders anschließen?
      CLT140, Piko BLX, LittleBee 20A, RCX1407-5000KV, Foxeer Micro, XM+
      E-Flite X-Vert Vtol, Unify, Foxeer Micro, SpektrumAIO
      KK90GT, PikoBLX, Cicada 10A, Aokfly 1104 7200KV, Caddx EOS2, XM+
      Toothpick mit Caddx EOS, AIO-FC, Happymodel 0703 19000KV, VTX03
      Mobula7 HD
      Schnatti ^^
      FrSky X-Lite
      Jugendliche, rechts und links 2000 Volt und oben brennt keine Lampe! :P :P
    • werderfuchs schrieb:

      Im Manual steht uart2.
      Yes, ich glaube dass ich aufs falsche Board geschaut habe. Kleines Problem ist, dass es jetzt mehrere Variablen gibt.
      Durch das flashen auf die neuste Version meinst du wahrscheinlich die ACCST 2.1.2 LBT firmware? Gibt da ja leider
      mehrere Möglichkeiten :) Wie @Orvo300 schon sagte muss man nun erstmal feststellen ob die Firmware von XM+ und Sendemodul nun passen,
      bis man auf das ursprüngliche Problem zurückkommt ^^
    • Nein, nix ACCST oder sowas. Der XM+ und die Funke reden miteinander! An einem anderen FC klappt alles.
      Ich habe den FC geflasht auf 4.2x
      CLT140, Piko BLX, LittleBee 20A, RCX1407-5000KV, Foxeer Micro, XM+
      E-Flite X-Vert Vtol, Unify, Foxeer Micro, SpektrumAIO
      KK90GT, PikoBLX, Cicada 10A, Aokfly 1104 7200KV, Caddx EOS2, XM+
      Toothpick mit Caddx EOS, AIO-FC, Happymodel 0703 19000KV, VTX03
      Mobula7 HD
      Schnatti ^^
      FrSky X-Lite
      Jugendliche, rechts und links 2000 Volt und oben brennt keine Lampe! :P :P
    • Das Target ist das geforderte. Den Betaflightconfigurator habe ich auch auf die neueste Version geupdated.
      Ich denke, es ist etwas mit dem sbus Pin faul. Kann man den remappen?
      CLT140, Piko BLX, LittleBee 20A, RCX1407-5000KV, Foxeer Micro, XM+
      E-Flite X-Vert Vtol, Unify, Foxeer Micro, SpektrumAIO
      KK90GT, PikoBLX, Cicada 10A, Aokfly 1104 7200KV, Caddx EOS2, XM+
      Toothpick mit Caddx EOS, AIO-FC, Happymodel 0703 19000KV, VTX03
      Mobula7 HD
      Schnatti ^^
      FrSky X-Lite
      Jugendliche, rechts und links 2000 Volt und oben brennt keine Lampe! :P :P
    • Für SBUS muss in der Regel an dem RX Pin ein Inverter vorhanden sein da SBUS als invertiertes Signal vom Empfänger ausgegeben wird. Deswegen gibt es bei F4 FCs extra das SBUS Pad. Einfaches remappen funktioniert also meist nicht.
      Wenn du auf ein anderen UART gehen willst der keinen Hardware-Inverter besitzt, dann kann man auch das invertierte SBUS Signal am XM+ abgreifen, muss aber dafür an ein sehr feines kleines Beinchen anlöten. Remappen ist dabei nicht nötig.


      Quelle: Oscar Liang

      F7 FCs kommen im Gegensatz zu F4 i.d.R. an jedem Pin mit invertierten Signalen zurecht.


      Beim verlöten vielleicht das falsche Pad am Empfänger erwischt? Ist mir auch schon passiert dass ich Signal und GND vertauscht habe ^^

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von Hazzahfpv ()

    • XM+ an Betafpv F411 AiO läuft nicht

      Ich habs mal hierher genommen. Ist ja jetzt schon ne lange Frage geworden.
      CLT140, Piko BLX, LittleBee 20A, RCX1407-5000KV, Foxeer Micro, XM+
      E-Flite X-Vert Vtol, Unify, Foxeer Micro, SpektrumAIO
      KK90GT, PikoBLX, Cicada 10A, Aokfly 1104 7200KV, Caddx EOS2, XM+
      Toothpick mit Caddx EOS, AIO-FC, Happymodel 0703 19000KV, VTX03
      Mobula7 HD
      Schnatti ^^
      FrSky X-Lite
      Jugendliche, rechts und links 2000 Volt und oben brennt keine Lampe! :P :P
    • Mann kann es auf der BetaFPV Page unter support lesen. Die Boards die ich mir angeschaut habe steuern alle den Receiver Eingang über Uart 2. Wie bereits von Wildflieger vorgeschlagen würde ich genau so vorgehen. Wenn es immer noch nicht angesteuert wird liegt wohl ein defekt auf dem Board vor. Hast du das Board neu oder ist es schon länger im Einsatz?
    • Das Board ist gebraucht von @bocholter. Vorher war crossfire angeschlossen.
      Ich habe noch einen Flysky Empfänger gefunden, den probiere ich mal noch aus.
      CLT140, Piko BLX, LittleBee 20A, RCX1407-5000KV, Foxeer Micro, XM+
      E-Flite X-Vert Vtol, Unify, Foxeer Micro, SpektrumAIO
      KK90GT, PikoBLX, Cicada 10A, Aokfly 1104 7200KV, Caddx EOS2, XM+
      Toothpick mit Caddx EOS, AIO-FC, Happymodel 0703 19000KV, VTX03
      Mobula7 HD
      Schnatti ^^
      FrSky X-Lite
      Jugendliche, rechts und links 2000 Volt und oben brennt keine Lampe! :P :P