Projekt Spark

    • Ist voll geworden - viel mehr geht nicht mehr rein in die Kiste.

      GPS und LEDs kamen heute noch dazu - GPS konnte ich schonmal erfolgreich auf dem Balkon testen.

      Ersatz ESC ist auch verbaut - Nun hoffe ich dass mir der Karren nicht wieder abfackelt. Bin schon ein bissl in der Bude hin und her geflogen - läuft eigentlich stabil ohne Zittern und Wackeln. Komisch - was das wohl war...

      Naja am WE kommt Testflug die 2.
      Bilder
      • 20210415_004839.jpg

        978,54 kB, 1.816×2.126, 12 mal angesehen
      • 20210415_020801.jpg

        525,41 kB, 1.730×1.497, 10 mal angesehen

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Onkel_Ho ()

    • Das unten links ist kein Cap sonder der Shunt für die Strommessung.

      Die beiden Fet‘s unten sind offensichtlich defekt.
      Kommt auf dem Bild jedenfalls so rüber.
      Der Fet oben rechts sieht verdächtig aus, kann aber auch ne verschmutzung sein.

      Der Grund für solche Ausfälle ist meistens nicht ermittelbar, außer Du hast ein Peripheres Problem oder deine Komponenten sind nicht passend.

      In Deinem Fall die Motoren.

      Dann geht der andere ESC ebenfalls drauf.
      Bilder
      • 91327534-51FF-4657-95B8-F40730688467.jpeg

        453,79 kB, 1.125×2.436, 14 mal angesehen
      Inhalt und Haftung
      Die enthaltenen Angaben erfolgen nach bestem Wissen und Gewissen des Forumsusers und basieren auf eigenen Erfahrungen. Diese können jedoch bei Anwendung im Einzelfall nicht zwangsläufig richtig sein. Die bereitgestellten Informationen und Ratschläge sind deshalb ohne jegliche Gewährleistung und das Risiko der Anwendung obliegt dem Nutzer.
      Die Nutzung der Infomationen erfolgt somit auf eigene Gefahr.
    • War das ein Mamba ESC?
      Falls ja, hatte ich sowas auch schon.

      Mein erster Mamba ESC hat starkes wackeln verursacht, so ähnlich wie in dem Video oben. Dieser ist mir dann mitten im Flug (nach ca 10 lipos ausgefallen). Ein anderer lief einen LIPO Perfekt, als ich den nächsten angesteckt habe, ging ein Motorausgang nicht mehr.

      Kann sicher auch andere Marken betreffen, vielleicht hattest du einfach Pech.
    • Ja, das wäre das Beste, denn der Ersatz ESC lief schon einige Zeit und da weiß ich dass er im Grunde OK ist.

      Der erste war neu und ja ist ein Mamba aus dem F405 Mini Stack (25A). Das Zittern kam mir auch komisch vor - so schlimm hatte ich das eigentlich noch nie. Die beiden ESCs haben auch unterschiedliche Revisionen - der neue war 301 und der gebrauchte ist 302.


      Ich hatte halt bei dem 1. auch 48khz laufen - hab jetzt Mal ganz konservativ auf 24khz gestellt. Wie gesagt in der Wohnung lief er normal ruhig ohne Zittern. Feldtest muss ich aber natürlich noch machen.
    • Sowas entsorgt man eigentlich nicht sofort sondern tut‘s in die Schrottkiste.

      Oftmals lässt sich aus 2 defekten Komponenten ein funktionsfähiges machen.

      Entsprechende Lötfertigkeiten mal vorausgesetzt.

      Ansonsten immer gut für Lötübungen solch Schrott.
      Inhalt und Haftung
      Die enthaltenen Angaben erfolgen nach bestem Wissen und Gewissen des Forumsusers und basieren auf eigenen Erfahrungen. Diese können jedoch bei Anwendung im Einzelfall nicht zwangsläufig richtig sein. Die bereitgestellten Informationen und Ratschläge sind deshalb ohne jegliche Gewährleistung und das Risiko der Anwendung obliegt dem Nutzer.
      Die Nutzung der Infomationen erfolgt somit auf eigene Gefahr.
    • Mache ich mal meine 2ct zum ESC: Du hast einen 220uF Elko an den ESC gelötet. Wenn der einen Kurzen bekommen, brennen dem einfach die Anschlussbeinchen weg. Das erklärt nix.
      Ein Mosfet hat ein Loch - oben rechts im Bild. Das ist ein durchaus klassischen Zeichen für einen Kurzen im Mosfet. Das wird dann heiß da drin und dann fliegt ihm der "Deckel" weg. In der Folge fließt über das ESC Board ein relativ großer Strom und das dürfte wiederum erklären, warum die anderen Komponenten weggebruzelt sind und die Leiterbahnen teils beschädigt wurden.
      Warum? - Zuviel Strom und wenig Airflow wäre meine Hypothese. Ein schlechtes Tuning kann die Ströme deutlich erhöhen. Mehr kann ich jedenfalls nicht erraten.
    • Nächster Test stand an:


      Ist nicht abgefackelt - ESC lief ordentlich egal welchen Akku ich dem zum Fressen gegeben habe. War also vermutlich defekt der alte ESC
      Fliegt aber immer noch Scheixxe... ||
      An 4s etwas besser als 3s aber ich bekomme das Teil nicht ordentlich getunt. Ich glaub ich muss mich echt mal intensiv mit BB beschäftigen. Oder halt mal Emuflight/FalcoX testen...
      Hier der BB Log zum Video: dropbox.com/s/m0yik4abrj6e5lo/btfl_all.bbl?dl=0
      Ohne Wind fliegt er fast ruhig - aber sobald der Wind etwas geht dreht der PID Controller frei. D-Term geht nicht höher als 40, danach glühen die Motoren. Was ich nicht probiert habe ist, P mal wesentlich runter zu drehen.

      Da ich aber jetzt GPS drinn habe: knapp 90km/h Top speed an 4s / 70 kmh an 3s 8)

      Die Frage ist, ob ich hier überhaupt noch weitertunen soll oder ob ich gleich andere Motoren drannmache... Soll halt ein Cruiser werden, aber zumindest auch halbwegs ruhig cruisen.
      Ich hatte mal an meine original Spark ne FPV Cam draufgeklebt - die flog eigentlich recht ruhig, also DJI hat da irgendwie nen besseren Job gemacht. Daher glaube ich schon, dass es tendenziell schon irgendwie gehen muss.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Onkel_Ho ()

    • Gyro Noise :/ - für mich als Laien sieht das irgendwie ziemlich viel aus...
      Zumindest scheinen die Filter zu laufen...
      Bilder
      • pitch filtered.JPG

        115,91 kB, 1.826×865, 5 mal angesehen
      • pitch unfiltered.JPG

        137,94 kB, 1.826×865, 6 mal angesehen
      • roll filtered.JPG

        107,98 kB, 1.819×857, 2 mal angesehen
      • roll unfiltered.JPG

        155,55 kB, 1.822×864, 5 mal angesehen
      • yaw filtered.JPG

        115,73 kB, 1.827×863, 4 mal angesehen
      • yaw unfiltered.JPG

        149,11 kB, 1.826×867, 6 mal angesehen

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Onkel_Ho ()

    • Hey, also das geht eigentlich - der "frame" ansich ist sogar relativ steif. Wichtig ist nur dass der Deckel drauf ist. Wenn der sitzt, kann man die Arme quasi kaum noch biegen. Natürlich kein Vergleich zu nem 4mm Carbon X-frame aber es ist echt ok.

      Der Deckel ist halt eigentlich verschraubt - aber ich hab den jetzt immer nur reingeklippt um schnell ans USB zu kommen. Sitzt ansich auch fest - hab aber noch LIPO Straps drumgemacht. Also 1-2mm kann man die Arme mit 2-3kg Kraft biegen. Aber die Props machen ja deutlich weniger Schub. Mehr als 200-220g wird das nicht sein pro Prop.

      Indoor fliegt der auch recht ruhig - aber sobald halt minimal Wind ist...
      Ich glaub ich muss den Mal von der Pieke auf anfangen zu tunen, dh. D auf null und erstmal P bis er einigermaßen Stabil ist und dann D hochfahren.

      CG hab ich auch Mal gecheckt - ist aber im Grunde derselbe wie bei der original Spark. Vielleicht 1mm weiter hinten. eher unwesentlich. Dennoch sehe ich im Log dass die Motoren hinten schon recht ausgelastet sind.

      Könnte halt Mal statt wie original Props in - Props Out probieren. Hat man halt n bissl weniger Yaw Washout....

      Aber du wirst lachen - ich hatte echt überlegt, den irgendwann Mal mit Carbon zu laminieren ;)

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Onkel_Ho ()

    • So wirklich trivial scheint der Frame nicht zu sein - zeigen ja auch Deine Plots. Vermutlich hat der Frame mehr als eine Resonanz. Häng den Kopter mal an einer Ecke auf und klopfe dagegen. Wie klingt das Ding? - Mach das mal mit einem Deiner gut fliegenden Racer. Vermutlich ist schon rein akustisch ein Unterschied da. Ich mache das immer mal, um Quellen für Resonanzen und losen Komponenten zu suchen. Schau auch mal, ob irgendwelche Kabel auf den Gyrochip "herum klappern". Generell nochmal nach klappernden Kabeln/Komponenten suchen. Die Hütte ist ja schon ziemlich voll.
      Hinzu kommen die wohl nicht so kraftvollen Motoren. Starke Motoren, insbesondere viel Ramp up Power macht Tuning einfach (und umgekehrt). DJI betreibt das Ding vermutlich in harmlosen Bereichen und man kann gar nicht so herum "heizen" wie Du in dem Video. Vielleicht doch mal über andere Motoren nachdenken?
    • Probiere ich mal mit den Resonanz-Test.
      Stärkere Motoren wäre natürlich immer eine Option, aber das würde das Resonanzproblem ja nicht verbessern. Auch das mit den Kabeln könnte sein - ich hab die meisten Kabel über den FC gelegt, Ich meine RX und TX von der Airunit laufen direkt über den FC.
      Ich hab ansonsten noch diese dünnen Flachen Carbonleisten da, mit denen man bei Flugmodellen die Flügel stabilisiert. Vielleicht klebe ich da mal testweise zwei Leisten längs an die Seiten bis hoch zu den Armen.
    • Neu

      Da hier gerade seit 3,5 Monaten Lockdown mit Ausgangssperre ist und ich Langeweile habe, hab ich mich nochmal n bissl mit der Spark beschäftigt. Die letzten Flugversuche waren ja eher frustrierend.
      Nun hab ich mal einfach was probiert was mir so ein bisschen wie letzte Hoffnung vorkommt und woran ich eigentlich bisher nie drann gedacht habe.

      Bisher mache ich bei nämlich bei allen Kopter die Props auf reversed - vor allem darum, weil mir kein Shit auf der Linse landet, wenns mal durch Blattwerk geht. Aerodynamisch gibts da sicher auch n paar Vorteile, aber das hab ich ehrlich gesagt bisher kaum gemerkt. Also hab ich das auch bei der Spark gemacht. Nun hab ich spasseshalber einfach mal in der Bude n paar Logs rumgehovert - Throttle soweit es geht hochgezogen und auch n bissl Roll und Yaw reingegeben - Pitch hab ich leider fast völlig vergessen :S - Und das ganze im Angle Mode, Acro trau ich mir mit nem 4,7 Zoll / 280g AUW teil nicht zu Indoor.

      Naja und ich sags mal so, die Logs sind recht unterschiedlich was Noise angeht. Ich hab bei Props-out horizontale Streifen drinn und wesentlich mehr Noise und bei Props-in siehts mir wie ein recht abgerockter Kopter aus - aber irgendwie nicht dramatisch so wie bei Props-out. Sagt mal, kann das sein, das das das Problem ist, dass der sich wie ein Haufen Scheiße geflogen hat?

      Hier mal zum Vergleich:

      3s Props-out (reversed)


      3s Props-in (normal):


      Bei 4s konnte ich den Throttle nicht mehr wirklich hochziehen, sonst gäbs Spraksalat...
      4s reversed:


      4s normal:


      Also an 3 und 4s ist das Gleiche - sobald die Props normal sind, siehts gleich wesentlich besser aus. Auch ist der Throttle response besser - Die Spark fühlt sich "kräftiger" an.
      Was mir noch aufgefallen ist, dass bei Reversed so horizontale Linien drinn sind und im unteren Throttlebereich noise quasi überall ist.
      Außerdem hab ich bei normal einen ominösen Spike bei um die 60hz - Ist das ein Problem? Bei Props Out ist der nicht :)


      Meine Vermutung ist, dass es irgendwie mit dem Design zu tun hat. Nach Chris Rosser hat man ja bei Props out die "schlechte Luft" hauptsächlich innen. Da nun aber die Props zum Teil auch über dem Frame liegen hat man dann so ne Art Ground Effekt vorne? Also ich meine dass sich unter den vorderen Props dann sowas wie eine Luftblase bildet, die nicht weg kann? Und das ganze schaukelt sich dann hoch wie Sau - Meine Vermutung ist, dass sich dann beim richtigen fliegen vor allem der I-Term so richtig schön hochschaukelt bis zum gehtnichtmehr. Das Problem ist ja vor allem bei den Props vorne - hinten ists glaube nicht das Ding.
      Wenn nun die Vorderen Props nach innen drehen hat man die schlechte Luft außen, da kannse dann weggedrückt werden. Ist nur ne Vermutung, vielleicht hat ja jemand von euch mehr Ahnung.

      PS. Wie ihr seht, hab ich den Deckel n bissl aufgebohrt - damit ich SD-Karte und USB einstöpseln kann ohne immer das ganze Teil auseinander zu nehmen - was mega nervig war und mit ein Grund warum ich keinen Bock mehr hatte da weiter zu machen. Nach jedem Flug erstmal 5 Minuten Deckel aufschrauben war der Überkrampf. So ists schonmal ne ganze Ecke bequemer.

      Nun meine Fragen:
      1. Da ich ja nicht richtig fliegen konnte. Ist dieser Log irgendwie aussagekräftig?
      2. Lieg ich richtig, dass es zwischen beiden Logs nen wesentlichen Unterschied gibt?
      3. Kann man das Teil überhaupt irgendwie so tunen und filtern, dass es halbwegs fliegbar ist? - Es soll ein reiner Cruiser werden, kein Hardcore Locked In Racer. Also Filter kann ich gerne hochdrehen. Meiner Meinung nach sieht mir der Log mit props In zwar nicht toll aber auch nicht dramatisch schlecht aus. Also weghauen oder weiterbasteln?
      4. Habt hier vielleicht noch andere Tipps, was Filter angeht?
      Ich kann leider nicht so wirklich testen - totaler Lockdown hier, könnte höchstens mal aufs Dach - da istn bissl mehr Platz.

      Wäre super, wenn sich jemand mal die Logs kurz reinziehen könnte - Danke vorab!

      Ich hab hier alle Logs mal hochgeladen:
      dropbox.com/s/yxcfb379kiqhh62/Logs.zip?dl=0

      Zum Setting
      PIDs etwas geraised per Slider / Filter Standard + RPM Filter Aktiv
      ESC: Blheli-S jazzmaveric 16.9 - 48khz / Rampup 0.25 / Demag High / Timing Medium High