Motoren drehen auf volle Leistung

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Motoren drehen auf volle Leistung

      Vorab schon mal ein Entschuldigung falls dieser Beitrag irgendwo ganz falsches drinnen ist, wusste nicht wie ich hier irgendwo eine Frage stellen konnte.

      Zu meiner Frage:

      Habe mir meine erste eigene Drohen selbst zusammengebaut. Soweit funktioniert auch alles, Funke verbunden, Kamere etc.
      Motoren reagieren in Betaflight auch alle.
      Nun wollte ich (natürlich ohne Props) erst mal schauen ob ich mit meiner Funke den Quad armen kann usw. und ob ich gas geben kann etc.
      Armen tut er und die Motoren laufen dann auch erst mal ganz ruhig und gleichmäßig. Wenn ich ein bisschen Gas gebe ist auch noch alles gut.
      Gebe ich jedech noch ein bisschen mehr Gas, dann drehen die Motoren auf volle Leistung hoch und ich kann das Gas nicht mehr regulieren.
      Wenn ich den Throttle ganz runter mache, dann gehen sie aus, aber dann kann ich gar nichts mehr machen.

      Hatte dann mal die Probs dran gemacht und dann nochmal probiert (ich weiß richtig blöde Idee).
      Habe den Quad dann oben festgehalten, dass er sich nicht rühren kann.
      Armen hat wieder wunderbar funktioniert. Als ich dann aber den Quad ein bisschen angehoben habe, haben die Motoren wieder versucht hochzudrehen
      und ich hatte das Gefühl als wollte sich der Quad überschlagen.

      FC ist richtig drauf und in Betaflight bewegt sich der Quad auch so wie ich ihn bewege.

      Hoffe mir kann jemand helfen, habe halt noch nicht so viel Ahnung von dem ganzen ^^
    • Prüf nochmal die Drehrichtung ohne Props und natürlich auch ob du die Props richtig rum rangebaut hast. Auch die Motoren sollten richtig durchnummeriert sein - Motor Mapping.
      Ansonsten kann das auch ganz normal sein wegen Airmode, vor allem wenn du den Kopter etwas bewegst und dann festhältst.

      Auf ner freien Wiese mal testen und weit genug vom Kopter stehen, dass er dir nicht ins Gesicht springt.

      Normalerweise Problem meiner Erfahrung nach:

      Kopter springt unkontrollierbar senkrecht nach oben: Props richtig rum, Motoren drehen vermutlich auch richtig aber Motormapping falsch / bzw. drehrichtung nicht in Betaflight eingestellt (reverse/normal)

      Kopter flipt: einzelne Props falsch drauf oder Drehrichtung einzelner Motoren falsch.

      Kopter dreht Motoren ohne ende hoch aber es passiert nichts: entweder alle Motoren drehen falsch / alle Props sind falsch drauf

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Onkel_Ho ()

    • Achso, also soweit ich gesehen habe, die jeweils Diagonal gegenüberliegenden Motoren drehen sich jeweils gleich, so wie es sein sollte.
      Nur glaube ich, dass diese sich jeweils genau anders herum drehen als es in Betaflight angegeben ist.
      Also könnte das das Problem sein?

      Und zu diesem Airmode. Ich hatte auf einen 3 Wege Switch bei der mittleren Position diesen Angle mode eingestellt, dass ist aber nicht das gleiche oder?
      Wo kann ich diesen Airmode einstellen oder was ist das genau?
    • Ja das ist definitiv ein Problem - sie müssen sich exakt so wie in Bf angezeigt drehen :)
      In dem Fall musst du dann die Drehrichtung in Blheli ändern. Auch die Motorenreihenfolge muss stimmen - sprich Motor 1 muss am Quad der gleiche Motor sein wie in Betaflight angezeigt (Hinten rechts) usw. Wenn nicht in der Kommandozeile von BF Motoren remappen.
      Drehrichtung kann man leicht mit den Fingern erfühlen oder falls du da nichts merkst nimmst halt ein nen Streifen Papier und hälst ihn gegen die Glocke. In die Richtung wohin sich das Papier biegt, dreht der Motor - ich musste das am Anfang so machen, mittlerweile geht's auch auf Sicht. :)
      Das ganze natürlich ohne Props - aber versteht sich ja von selbst,

      Airmode findest bei Bf 4.2 unter Konfiguration das ist einer der Schieber - für den Initialen Test mach ich den immer aus. Denn wenn irgendwas falsch ist, macht es Airmode immer schlimmer.

      Zum Testverfahren mit Props (Airmode aus)
      Geh in den Acro Mode (angle Mode aus)
      Stell den Kopter auf den Boden
      Arme
      Sobald die Props drehen, Pitch ganz leicht nach vorne - der Hintern des Kopter sollte sich heben. Dann leicht nach hinten Pitchen bis die Nase sich leicht anhebt.
      Danach Roll left und roll right - gleiche Methode.
      Zum Schluss je nach dem wie sicher du bist entweder angle Mode rein oder eben aus lassen und ohne Pitch und Roll leicht throttle geben bis der der Kopter etwa 1-2 Meter über dem Boden schwebt. Dann nochmal alle Achsen Kurz antesten - jetzt auch yaw.

      Auch Mal ein paar kurze Gasstöße geben um zu sehen ob die Filter halbwegs ok sind oder es ein elektrisches Problem gibt (Desync oder FC Reboot)

      Wenn alles OK ist, kannst du airmode wieder in BF einstellen. Oder mach's wie ich leg ihn dir einfach auf einen Switch bei den Flight modes. Ich hab die auf dem 3 Wege Schalter.
      1 - Angle Mode (Airmode aus)
      2 - Acro Mode (Airmode aus)
      3 - Acro Mode (Airmode an)

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von Onkel_Ho ()

    • Alles klar, danke dir. :)
      Werde ich dann später mal gleich ausprobieren ich hoffe damit funktioniert es dann.
      Würde gerne einen like da lassen, nur anscheinden habe ich dafür nicht die "Berechtigung"? ?(

      Achja ein anderes Thema noch, da ich meinen ESC/FC mit BF updaten wollte, habe mir die richtige Firmware runtergeladen, aber wenn ich sie dann
      drauf laden will steht oben links irgendwas mit Port nicht erkannt oder dergleichen.
      Jedenfalls geht das nicht.
      An was könnte das liegen?
    • @Rydnik

      Du hast gar kein Problem.
      Das die Motoren ohne Propeller nach einem Gasstoss immer schneller werden ist normal und hat jeder Kopter!
      BF setzt den Gasstoss um und merkt über den Sensor das der Kopter sich nicht bewegt und gibt automatisch immer mehr Gas.
      Wenn der Kopter gearmt ist und er wird von Hand bewegt versucht er sofort mit den jeweiligen Motoren die Lageveränderung auszugleichen.

      Ein Problem ist es erst wenn die Propeller drauf sind und er sich beim Versuch abzuheben auf den Kopf legt.
      Dann stimmt die Drehrichtung der Motoren nicht oder die Propeller sind falsch montiert.
      --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
      wer rechtschreibfehler findet darf diese gerne behalten.
      Frei nach Nuhr: "Wenn Du von einem Thema keine Ahnung hast, einfach mal die Fresse halten"

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Jo_Nopp ()

    • Also haben alle Motoren in blheli umgekehrt, sodass sie genau so laufen wie in bf und siehe da, es funktioniert.
      Motoren laufen alle gleich und ich kann gas geben.
      Erste Testflug wurde auch schon gemacht und alles lief super.
      Danke nochmal. :)

      Jetzt würden dann doch noch ein paar Fragen folgen.

      1. Das updaten des FC mit BF? warum steht dort Port geht nicht oder dergleichen wenn ich flashen will?
      2. Ich habe die DJI Goggles und wenn ich diese anmache, dann steht dort, dass ich im Stromsparmodus bin. Ist das irgendein Problem?
      Dort stehe auch, dass ich deswegen derzeit nicht aufnehmen kann?
    • 1. Hast Du vorher auch keinen Zugriff auf den FC gehabt?
      Generell muss der FC vor dem flashen in den Bootloader Mode gebracht werden. Also Knöpfchen am FC drücken und halten und dann den USB Stecker dran...
      2. Das ist normal. Bis Du den Copter gearmt hast. Kannst im Menü der Brille die automatische Aufnahme wählen oder manuell die Aufnahme mit dem roten Knopf an der Brille starten.
    • zu 1. Weiß ich jetzt nicht mehr genau ob es am Anfang ging. Nur jetzt geht es eben nicht mehr.
      Das mit den Knöpfchen drücken und halten und dann anstöpseln hatte ich glaub ich schon probiert, aber probier ich nochmal.
      Aber müsste nicht auch, wenn ich den FC an den PC stecke im Verzeichnis ein "USB Device" aufgelistet sein? Oder täusche ich mich da?

      zu 2. OK, muss ich dann mal beim fliegen schauen. Was ich noch gelesen habe ist, dass die Brille mit 25mW läuft, aber man das auch noch höher stellen kann.
      Ist das sinnvoll? Ist dadurch dann die Reichweite besser?
    • also ich würde erst mal fliegen.
      Hier sind genügend Beispiele im Forum das man sich, gerade als Anfänger, jede Menge Frust ins Haus holen kann nur weil man meint
      die neueste Firmware/BF auf dem FC etc. haben zu müssen.

      Und -> ich habe noch nie irgendein Knöpfchen drücken müssen um den FC zu flashen.
      --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
      wer rechtschreibfehler findet darf diese gerne behalten.
      Frei nach Nuhr: "Wenn Du von einem Thema keine Ahnung hast, einfach mal die Fresse halten"
    • Ja ok, fc flashen werde ich erst mal nicht. Bin heute erst wieder geflogen leider ohne goggles, da ich die cam falsch rum montiert hatte, war alles auf dem kopf :whistling:

      Ich hätte da noch zwei Fragen.

      1. Wenn ich die Dji goggles anmache und den Quad arme steht in der Brille nicht wie viel akku der lipo noch hat. Muss ich da noch was einstellen?
      2. In der Brille steht immer, egal ob gearmt oder nicht,: "Stromsparmodus, Aufnahmen nicht möglich". Woran liegt das? Im Internet finde ich dazu leider nichts.
    • kann ich dir leider nicht weiter helfen.
      fliege analog.
      --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
      wer rechtschreibfehler findet darf diese gerne behalten.
      Frei nach Nuhr: "Wenn Du von einem Thema keine Ahnung hast, einfach mal die Fresse halten"
    • Also vielen Dank nochmal an alle.
      Es funktioniert jetzt alles.

      Musste in BF nur de uart umstellen, da war der falsche drinnen. Jetzt sehe ich den akku und kann aufnehmen :D

      Jetzt wäre meine finale Frage nur, bringt das etwas, wenn man die Brille auf 700mw oder wie viel auch immer laufen lässt?
      Weil standard ist ja bei uns in Deutschland 25mw oder?
    • Ok danke.
      Noch eine andere Frage.
      Ein Kumpel von mir hat di Dji mit der Drohne usw.
      Wir wollten diese in den Acromodus bringen. Alles eingestellt in dee Brille und an der Funke usw. So weit so gut.
      Aber der Stick zum gas geben reagiert dann erst ab der Mitte. Ist das normal?
      Eigentlich sollte ja schon ganz unten gas kommen. Und wenn man den Stick dann wieder ganz runter macht, dann gehen die Motoren aus. Muss man da noch etwas einstellen?