Nazgul 5 HD, frsky rxsr, radiomaster TX16S - kein Ausschlag in Betaflight

    • Nazgul 5 HD, frsky rxsr, radiomaster TX16S - kein Ausschlag in Betaflight

      Ich bin neu und komme leider beim Setup nicht mehr weiter, freue mich sehr über Hilfe, vielen Dank!

      Betaflight, keinerlei Ausschlag; Einstellungen wie hier beschrieben: myosuploads3.banggood.com/prod…ghtSucceX-E-F4-MANUAL.jpg

      Rxsr mit rxsr_accst_2.1.0_LBT.frk erfolgreich geflashed
      Rxsr ist nicht in PPM mode (led blau und grün leuchtet)

      Binding erfolgreich mit Telemetrie


    • Der Funke ist es eigentlich egal ob SBUS oder FPORT. Das bezieht sich ja nur auf die Kommunikation zwischen Empfänger und FC, mit der entsprechenden Verkabelung und Einstellungen in Betaflight.
      Die Kommunikation zwischen Funke und Empfänger bei FrSky ist halt mittlerweile nicht so einfach geworden da es zu viele Varianten gibt:

      - ACCESS v1.x (eine Firmware aber umschalten zwischen FCC und LBT möglich)
      - ACCESS v2.x (eine Firmware aber umschalten zwischen FCC und LBT möglich)
      - ACCST v1.x EU LBT
      - ACCST v1.x FCC
      - ACCST v2.x EU LBT
      - ACCST v2.x FCC
      - FrSky D8

      Ist aber hier ja irrelevant, da der Empfänger gebunden zu sein scheint (grüne LED) und die TX16S keine besondere Firmware benötigt (man muss dort nur im Multi-Modul das richtige Protokoll gewählt haben - da gebunden, wohl richtig ausgewählt).
    • Ich habe mich an diesen Plan gehalten:
      blog.seidel-philipp.de/wp-cont…chlussplan_Wiringplan.png

      Mein Anschlussplan findet sich im Anhang.
      Es ist definitiv S.Port (also wohl der FPort Anschluss) und nicht SBUS.
      Ich hoffe sehr, dass T1 an FPORT korrekt ist (obwohl ich den Succex-E F722 habe).

      Oder gilt folgendes und FPORT muss an T2?
      rotorama.cz/cms/assets/docs/8d…diagram_60945de95ef57.png

      Das wäre natürlich fatal...

      Und dann muss ich die ACCST_2.1.1_fport_lbt firmware flashen ;)

      Vielen, vielen Dank für die Hilfe!!
      Bilder
      • SAVE_20211228_200725.jpg

        358,75 kB, 2.048×1.351, 14 mal angesehen
    • Ich bin, dank der gezielten Fragen und Hinweise, schon nah am Ziel (hoffe ich), eine Antwort auf mein letztes posting wäre noch sehr hilfreich.
      Muss ich T2 Succex-E F722 mit fport Rxsr verbinden?
      Warum funktioniert das binding auch bereits jetzt (oder hat das nicht miteinander zu tun?)

      Vielen Dank!
    • Binden zwischen Sender und RX hat nichts mit dem FC zu tun, sondern ist lediglich die Kommunikation zwischen Sender und RX. Als nächstes muss dann der RX mit dem FC kommunizieren. Das läuft dann über die UARTs. Hier muss dann der RX und der FC die gleiche Sprache sprechen. Also SBUS oder FPort. Dafür muss der UART entsprechend verkabelt und eingestellt werden. Wenn der RX mit FPort kommunizieren soll, dann muss der FPort vom Rx an einem freien UART des FC an Tx angeschlossen werden und der UART entsprechend in BF eingestellt werden. Hierbei ist es jetzt bei F7 FC meist egal welcher UART es ist, wichtig dabei ist nur, dass er noch frei ist und kein anderes Gerät am gleichen UART hängt. Weiterhin muss der UART natürlich noch in BF auf das entsprechende Gerät/ Protokoll eingeszellt werden, damit der FC auch weiß, was er mit den Signalen, welche an dem UART ankommen, anfangen soll.
      Goblin Helis bis 800er Speedmod
      Racequads, AR-Wing Pro, Funjet Ultra 2 FPV Mod alles mit DJI digital FPV
      Div. Flächenflieger
      Horus X10S Express, Taranis X-Lite S
    • need_help schrieb:

      Oder gilt folgendes und FPORT muss an T2?
      MUSS nicht. Kann an einen beliebigen UART, aber wie @catdog79 schon sagt dann an das T-Pad (T1, T2, etc.)

      Für FPORT folgendes und es SOLLTE funktionieren:

      - Auf dem Empfänger muss die FPORT Firmware geflasht sein
      - Anschluss so wie du es gezeichnet hast: S.PORT Pin an ein T-Pad
      - Im Ascnhlüsse-Tab in Betaflight "Serieller Empfänger" bei dem UART aktivieren an den du den Empfänger angeschlossen hast (T2 ist UART2, T1 wäre UART1)
      - Falls du Betaflight 4.2 nutzt: Im Konfigurations-Tab unter Empfänger einmal "Serieller Empfänger (SPEKSAT...)" wählen und darunter "FrSky FPORT".
      (Falls du schon Betaflight 4.3 nutzt: Dort ist diese Einstellung in den Empfänger-Tab verschoben worden)
      - In der Kommandozeile folgende Befehle eingeben:

      set serialrx_halfduplex = on
      set serialrx_inverted = on
      save

      danach SOLLTEST du im Empfänger-Tab Ausschläge sehen wenn der Empfänger mit der Funke gebunden ist und du die Sticks bewegst.

      EDIT: Ich empfehle dir auf den Empfänger die ACCST v2.1.0 FPORT LBT Firmware zu flashen (nicht die 2.1.1). Im Mai fand ich heraus, dass die Version 2.1.1 evtl. Probleme
      bei der Übertragung der Betaflight-Telemetrie hat. Vielleicht hat sich diesbezüglich etwas von Seiten FrSky getan, aber bezweifle ich ein bisschen.
      Hier mein damaliger Post dazu: Betaflight, Tinyhawk Freestyle II (MATEKF411RX) mit R-XSR und bidirektionalem DSHOT

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von Hazzahfpv ()

    • Hazzahfpv schrieb:

      - In der Kommandozeile folgende Befehle eingeben

      set serialrx_halfduplex = on
      set serialrx_inverted = on
      save

      Muss man das immer noch machen? Habe jetzt auf dem Fusion Jet nun INav drauf mit Matek F765 und dort funktioniert es ohne diese CLI Eingabe. Dafür setzte ich doch im Config oder Receiver Tab die Einstellung auf F-Port.
      Kann aber tatsächlich auch Zufall bei mir sein. Habe es jetzt das erste Mal mit FPort Protokoll gemacht. Davor hatte ich immer SBUS und SPort für Telemetrie getrennt gelassen.
      Goblin Helis bis 800er Speedmod
      Racequads, AR-Wing Pro, Funjet Ultra 2 FPV Mod alles mit DJI digital FPV
      Div. Flächenflieger
      Horus X10S Express, Taranis X-Lite S
    • Gute Frage ob BF das mittlerweile automatisch konfiguriert sobald man FPORT wählt. War "damals" jedenfalls noch nicht so. Jedoch kann BF ja nicht wissen ob man FPORT invertiert oder nicht invertiert angeschlossen hat, also zumindest den "inverted"-Befehl würde ich eingeben,
      der Rest kann ja eigentlich nicht schaden.
    • Also zumindest meine Kakute F7 HDVs und offensichtlich auch der Matek F765 WSE erkennen automatisch ob das Signal invertiert werden muss oder nicht. Keine Ahnung ob das ein spezial Feature dieser beiden FC‘s ist, oder nicht. Meine aber mal gelesen zu haben, dass dies jedes F7 Board kann.

      Ist aber auch egal, solange es mit dem CLI Befehl funktioniert. Dauer ja auch nicht lange die beiden Befehle einzugeben.
      Goblin Helis bis 800er Speedmod
      Racequads, AR-Wing Pro, Funjet Ultra 2 FPV Mod alles mit DJI digital FPV
      Div. Flächenflieger
      Horus X10S Express, Taranis X-Lite S
    • catdog79 schrieb:

      Muss man das immer noch machen?
      Habe das eben mal schnell mit meinem Whoop getestet. Hat einen R-XSR mit ACCST v2.1.0 FPORT LBT verbaut, der FC ist mit der aktuellsten Nightly von BF 4.3 geflasht.
      FC Werksreset gemacht und UART/Empfängereinstellungen nach und nach neu eingegeben. Ausschläge im Empfänger-Tab waren erst nach Eingabe der Befehle
      in die CLI wieder zu sehen.
    • Ein F4. Habe jetzt jedoch extra auch meinen 6" auseinandergenommen um den R-XSR an dessen Kakute F7 anzuschließen. Auch hier kompletten Werksreset gemacht
      und nach und nach Empfänger und UART konfiguriert. Ausschläge waren erst nach Eingabe der CLI-Commands zu sehen. Ebenfalls Betaflight 4.3 aktuellste Nightly.
    • Ok, dann scheint es wohl eine Eigenart des Matek F765 WSE zu sein.
      Oder es liegt an INav. Dort habe ich nur F-Port ausgwählt und sonst nichts gemacht und es hat auf Anhieb funktioniert.

      Danke dir für deine Tests, das werde ich mir jetzt merken.
      Könnte mir beim nächsten mal dann viel Arbeit ersparen wenn es nicht sofort funktioniert. ;)
      Goblin Helis bis 800er Speedmod
      Racequads, AR-Wing Pro, Funjet Ultra 2 FPV Mod alles mit DJI digital FPV
      Div. Flächenflieger
      Horus X10S Express, Taranis X-Lite S
    • Jetzt wo du es sagst. Ich hab' hier auch noch einen unverbauten Matek F765 liegen der eigentlich in meinen Segler sollte. War bisher nur zu faul und dann hab' ich vergessen dass er noch im Bastelkoffer liegt.
      Probiere das später nochmal mit dem auf INAV und Betaflight. Interessiert mich jetzt auch ^^
    • Ich glaube ich weiß warum es funktioniert hat, ohne dass ich was einstellen musste.
      Matek hat wohl einen extra UART für FPORT. Da ich zumindest manchmal auch die Anleitung lese, habe ich den Empfänger wohl wie im Schaltbild angeschlossen. :D

      Vermute, dass der UART schon entsprechend vorkonfiguriert ist. Ist der UART6 (TX6).


      Goblin Helis bis 800er Speedmod
      Racequads, AR-Wing Pro, Funjet Ultra 2 FPV Mod alles mit DJI digital FPV
      Div. Flächenflieger
      Horus X10S Express, Taranis X-Lite S

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von catdog79 ()

    • Neu

      Um das eigentliche Thema für zukünftige Leser abzuschließen:
      Der Nazgul5 HD wurde ohne Empfänger bestellt, daher war die Caddx Vista vom Werk für SBUS über den Stecker an der Unterseite
      des FC verkabelt (nicht direkt einsehbar). Die Caddx belegt also UART1 für die MSP verbindung und UART2 für SBUS.
      Beim anlöten des R-XSR kam es also zu einer Doppelbelegung des UART.
      SBUS der CADDX nun von UART2 entfernt und den R-XSR auf UART2 (T2) umgelötet.
      Die oben genannten Befehle in der CLI eingegeben und gespeichert. FPort Signale des R-XSR kommen nun in Betaflight an.