Blackbox Log Analysen

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Blackbox Log Analysen

      Ich erstelle hier nochmal den Thread für Blackbox Analysen aller Art.

      Hier können alle mal ihre BB Logs posten, damit man mal darüber sprechen kann, was noch an den Pids/Einstellungen verbessert werden kann.
      Generelle Info für alle:
      https://github.com/c...ocs/Blackbox.md
      Damit das alles sinnvoll ist bitte folgende Sachen beachten/angeben:
      • BB Log in den Anhang

      • Am besten eine Log Rate von ca. 1kHz einstellen (darüber ist es Datenmüll, darunter kann es zu Aussetzern und Aliasing kommen)

      • BB Log möglichst klein halten und nur für den Flug das Logging per Switch aktivieren (müsst sowieso ihr für 45 Minuten dann die 8MB aus dem Speicher ziehen) wenn nur ein Log in der Datei ist, ist es auch leichter zu finden.

      • BB Log am besten von Betaflight 2.8 oder höher, ansonsten einen CLI dump in eine *.txt Datei speichern und auch hinzufügen (Cleanflight, Raceflight und iNav gehen auch! Aber auch CLI dump machen)

      • Beim Log rumkurven, Flips machen, 180° Wendungen (also Richtungswechsel), Gasstöße ohne zusätzlichem Input, je mehr sinnvolle Moves gemacht werden, umso mehr kann man am Log sehen

      • Setup angeben; Rahmen, Motoren, ESC, Propeller (!!), FC, Gewicht (halt alles was wichtig sein kann)

      • Software Versionen angeben; von FC und ESC!

      • Video dazu wäre richtig toll, damit kann man noch mehr rausholen, dabei Beeper zum syncen verwenden bzw. am Start kurze Gasstöße. Wenn ihr die Sync Zeit angebt, gibts Bonuspunkte und eine Runde Applaus!



      EDIT: zusätzlich möchte ich noch meine Methode zur Gyrodämpfung hier ein wenig fest halten, falls jemand Probleme mit Vibrationen hat:

      kopterforum.de/topic/56967-vibrationen-dämpfen/?p=814970

      Oder diese Raceflight Dämpfer, um die FC komplett zu entkoppeln:

      Raceflight Bestellung Dämpfer und FC
      Je weniger du selber machst, desto weniger machst du auch falsch :P

      youtube.com/channel/UCk9YaxVYP-2_AHr3etFYy5A
      airvuz.com/user/binding
      :saint:

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von bind.ing ()

    • Hallo.

      Ich hatte mein Problem ja hier schon beschrieben und komme nicht so recht weiter.
      Daher folge ich der Bitte von bind.ing und stelle mal von meinem letzten Flug das Log online.

      Software ist BF 3.0.1 und BlHeli 16.4

      Mein Log ist 5,47mb groß.
      Mag mir bitte nur noch jemand erklären wie genau ich das hier anhänge ?(
      Realacc210, AirbotF4, Racerstar V2 30A, RS2205, KK 5040
      Realacc K130, OmnibusF3, Racerstar V2 4/1 20A, Tornado T1 1407, DYS 3045
      GEPRC Leo, Flame F4, Labs 28A, LD Power FR2305, DAL Cyclone
    • Welche Funke hast du? Deine Stickmovments sehen manchmal hakelig aus, probier eventuell mal RC smoothing zu erhöhen.

      Leider sieht man nicht, wann du fliegst, und wann du stehst bzw driftest. Da wär ein gesynctes Video noch gut, ist aber die Frage ob man das sieht. Darum stell ich jetzt nur Vermutungen auf, die zu deinem Problem passen können.

      Generell fällt mir zb beim zweiten Log bei Minute ca 1:40 auf, dass die Rollache immer leicht im Minus ist.

      Funke getrimmt? Endpoints auf 1000 und 2000 bzw Mitte auf 1500? Immer? Du kannst auch deadband auf der Achse ein wenig höher stellen. Wäre ja dann Roll?

      Das war alles im Horizon? Eventuell gehören die level Pids höher. Besteht irgendwas komisches auch in Acro?
      Je weniger du selber machst, desto weniger machst du auch falsch :P

      youtube.com/channel/UCk9YaxVYP-2_AHr3etFYy5A
      airvuz.com/user/binding
      :saint:
    • Ich habe die Spektrum DX9.
      Ich muss vielleicht dazusagen das ich beim ersten Log tatsächlich kurzzeitig ein bisschen hektisch geworden bin weil mir das Ding fast entflogen ist :D
      Ich musste notlanden und ein paar hundert Meter durchs Feld joggen .

      Den zweiten Log habe ich bewusst kurz gehalten und bin nur gestartet und hab das Ding rollen lassen.
      Je mehr Rollen ich mache umso mehr steht er hinterher in die gleiche Richtung schief.

      Wie kann man das machen das das grafisch mit Sticks dargestellt wird ?

      Rollachse leicht im Minus. Hmm. Die Mitte ist auf 1500 eingestellt und tanzt +-1
      Aber davon kommt ja nicht die Schräglage :(

      Deadband werde ich mal suchen in der Funke. War bisher nicht nötig.

      Alles im Horizon ja. Fliege ausschließlich LOS und übe wenn ich viel Mut habe LOS Acro.
      Aber im Acro fällt mir nichts merkwürdiges auf.

      Was genau meinst mit Level PID.
      Stehe auf dem Schlauch entschuldige.
      Realacc210, AirbotF4, Racerstar V2 30A, RS2205, KK 5040
      Realacc K130, OmnibusF3, Racerstar V2 4/1 20A, Tornado T1 1407, DYS 3045
      GEPRC Leo, Flame F4, Labs 28A, LD Power FR2305, DAL Cyclone
    • Aaah klar.
      Okay da habe ich schon geschraubt auf 80 bei Horizon.
      Hat aber auf die Schieflage keinen Einfluss gehabt.
      Was mir bei Dir jetzt aber auffällt.
      PID Math: Float
      Derivate Mthod: Measurement.

      Glaube da steht bei mir:
      xxx und Betaflight

      Ich mach mal nen Screenshot heute Abend.
      Realacc210, AirbotF4, Racerstar V2 30A, RS2205, KK 5040
      Realacc K130, OmnibusF3, Racerstar V2 4/1 20A, Tornado T1 1407, DYS 3045
      GEPRC Leo, Flame F4, Labs 28A, LD Power FR2305, DAL Cyclone
    • Okay.

      Ich bekomme in nächster Zeit den gleichen FC nochmal weil ich Ihn in meinen Firebold gegen die Naze tauschen wollte.
      Ich werde den mal im Realacc tauschen und schauen ob der erste FC ne Macke hat.
      Bis dahin würde ich aber gern noch daran arbeiten das hinzubekommen weil ich mir das nur schwer vorstellen kann.
      Wie gesagt, nagelneu und nie runter gefallen.
      Verpackt war er auch ordentlich.

      Was kann ich noch tun damit wir der Sache auf den Grund kommen ?(
      Realacc210, AirbotF4, Racerstar V2 30A, RS2205, KK 5040
      Realacc K130, OmnibusF3, Racerstar V2 4/1 20A, Tornado T1 1407, DYS 3045
      GEPRC Leo, Flame F4, Labs 28A, LD Power FR2305, DAL Cyclone
    • Schön zu sehen dass du dich PID Tuning Sache hier im Forum annimmst.
      Gefällt mir.

      In einem Punkt wiederspreche ich dir allerdings:

      bind.ing schrieb:

      Am besten eine Log Rate von ca. 1kHz einstellen (darüber ist es Datenmüll, darunter kann es zu Aussetzern und Aliasing kommen)
      Was meinst du mit Datenmüll? Habe ich persönlich noch nie im BBlog gesehen egal wie hoch die Log Rate war.
      Die Log Rate sollte IMHO mind. 50 % bis 100 % sein.
      Die aktuellen F4 FCs fliegen problemlos mit PID loops von 8 kHz der Revolt sogar 32 kHz.
      Wenn du strikt immer mit 1kHz aufzeichnest geht dir da eine Menge an Infos durch die lappen und z.B. Oszis wirst du schwerer oder gar nicht sehen.
      Slack Chat:
      fpv-racing-forum.slack.com/
      Für Invite Link einfach per PN melden.

      YT:
      youtube.com/channel/UC8C8o4A19v5ryuY4Zcy1sxQ
    • Hi, gerne

      Datenmüll meinte ich unnötige Daten. Und viele FCs können nur 8 oder 16MB Speichern, die sind mit 1k schon relativ schnell voll. Ca 4 Minuten für 8Mb soweit ich weiß. Und dann muss man erstmal eine dreiviertel Stunde warten, bis das Log per USB herunter geladen ist.

      Warum soll mir das was durch die Lappen gehen? Die relevanten Oszillationen sind zwischen 150 und 300 Hz, was bringt mir dann 8kHz? Diese Geschwindigkeit brauche ich auch nur für die Notch Filter, der Rest liegt irgendwo zwischen 10 und 100Hz, was fürs Tuning verwendet werden kann.

      Hast du einen Vergleich zwischen 8k und 1k, wo Daten nicht zu sehen sind bei 1k? Ich hab keine F4, darum kann ich nicht so weit rauf, bei 4k ist Schluss. Außerdem muss ja der Speicher da mit kommen.. Im Read sind sie die SPI Flash ja nicht unbedingt schnell..

      Womit loggst du ?
      Je weniger du selber machst, desto weniger machst du auch falsch :P

      youtube.com/channel/UCk9YaxVYP-2_AHr3etFYy5A
      airvuz.com/user/binding
      :saint:
    • Was mir bei dem BB log als erstes aufgefallen ist, Du hast keinen Airmode an. Absicht? Deswegen trudelt der auch bei min throttle so stark bei loops auch über die Rollachse (2. log ab 47.251).
      Ausserdem finde ich deinen P wert auf der Roll achse viel zu lasch. P greifft viel zu wenig ein wenn du rollen machst und am Ende übersteuert dein Gyro Wert weit über den RC command hinaus, weil er nicht genug P abbekommt (2.log bei 16.217)

      Ich würde P auf Roll mal auf 50 oder 55 erhöhen und nochmal loggen ob es schon oszillationen gibt.

      D und I finde ich auf Roll und Pitch Achse jetzt so erstmal ok.
      Wenn fliegende Fliegen hinter fliegenden Fliegen fliegen, fliegen fliegende Fliegen fliegenden Fliegen nach, nicht fliegende Fliegen dagegen nicht.
      youtube.com/channel/UCu0lFX2G-NawTtYDgMWzLdw
    • Hi erstmal danke für´s ansehen.
      Airmode bin ich mir relativ sicher war an. Müsste mich sehr täuschen.
      Das sind die Stock PID von BF 3.0.1.
      Ich habe das auch schon vermutet und werde das mal anpassen entsprechend Deiner Tips.
      Sobald mich das Wetter lässt mache ich einen neuen Log und stelle Ihn ein.
      Vielen Dank Euch.
      Realacc210, AirbotF4, Racerstar V2 30A, RS2205, KK 5040
      Realacc K130, OmnibusF3, Racerstar V2 4/1 20A, Tornado T1 1407, DYS 3045
      GEPRC Leo, Flame F4, Labs 28A, LD Power FR2305, DAL Cyclone
    • hab grad nochmal geschaut, beim 2. log war der airmode tatsächlich über einen schalter an. Ok, egal. Ich würde trotzdem auch dringend empfehlen im Acro mode zu fliegen, auch wenn es als eine Hürde vorkommt, aber es ist so viel besser und bringt so viel mehr fun!
      und natürlich die PID sache einstellen ...
      Wenn fliegende Fliegen hinter fliegenden Fliegen fliegen, fliegen fliegende Fliegen fliegenden Fliegen nach, nicht fliegende Fliegen dagegen nicht.
      youtube.com/channel/UCu0lFX2G-NawTtYDgMWzLdw
    • Hi zusammen,
      ich muss hier wohl auch mal ein Blackbox vid einstellen, da ich gerade ein wenig ratlos bin aus welcher Richtung ich die Probleme angehen muss. :|

      1. Zum SetUp:
      Der Kopter ist eine Vortex 250Pro die ich auf 6" umgebaut habe mit selbst modellierten und von Noblish gefrästen 6" Armen.
      ziel des Umbau war es meine etwas schwer-fällige 5" Vortex, die ich nicht mehr viel geflogen bin weil sie einfach mit dem RefleX nicht mithalten kann, in einen Raketen-Cruiser zu verwandeln der dann vielleicht aufgrund der sehr unterschiedlichen Flugeigenschaften auch wieder von mir beflogen wird

      FC: Fusion Gen2 mit Betaflight 3.0.1
      ESCs: Stock ESCs (20-22A)
      Motoren: T-Motor F40 v2 2300kv (2205er)
      Props: Gemfan 6x4.5 nicht-BN GF (auf Video) oder HQ 6x4.5 nicht BN GF (machte keinen Unterschied)
      Akkus: 4S (im Vid SLS Quantum 4s 1500er 65C)

      2. Hier mal eine kurze Abhandlung meiner ersten 3 Flüge damit:

      1. Flug: Stock Betaflight PIDs, kurzer Punchout hat sich einmal quer über alle Achsen überschlagen selbst im Angle Mode. Zu erwarten bei 6" Props, daher erstmal YAW P runter - Problem gelöst.
      Bin nur LOS ein wenig gecruised aber Motoren klangen nicht sauber. Daher Brille auf siehe da, massive Oszillationen schon bei ca 40% throttle. Also Ps runter und nochmal geflogen, dasselbe. Ds und Is runter und Ps noch weiter bis fast zur unfliegbarkeit, dasselbe.

      2. Flug: Hatte ich keine Lust mehr auf tunen, wollte einfach den Pack mal leer fliegen, also Stock PIDs wieder rein, YAW P runter und mal gib ihm übers Feld - Das war dann der Moment als die Lichter aus sind. 140A hatte es unten noch angezeigt - bis die gute Taranis den phösen "Telemetry lost" Spruch abgelassen hat

      Man hat dann den Kopter im Feld gerochen bevor man ihn gesehen hat :S zu deutsch: gar nicht gut:



      nach langem Suchen hatte ich dann die Ursache gefunden. Bin mir nicht sicher ob das eine "solldurchbrennstelle" ist oder nicht, jedenfalls ist sie jetzt mit einem ordentlichen Berg Lötzinn wieder überbrückt :)

      Anschließend habe ich noch nacheinander 2 Motoren getauscht was aber auch keine Verbesserung gab.

      3. Flug: Taranis auf 75% throttle max eingestellt, damit ich nix durchbrenne, PIDs hoch runter links rechts :P, habe einfach keine Richtung gefunden in der die Oszis besser wurden!

      3. Vid

      Daher jetzt kurz ein Vid mit Blackbox log gemacht. Sind nur kurze punchs LOS auf einer kleinen Wiesenfläche LOS. max 75A draw - dementsprechend stärker können die noch werden.
      Sorry für DVR footage, aber wie ihr auf dem Video sehen könnt ist die RunCam oben entkoppelt und man sieht daher die Oszis nicht!

      Achtung: Audio aus!


      Und bevor alle das Setup zerreißen noch ein paar vorab Stellungnahmen :D

      1. EzESCs sind für 20A dauer und 22A gerated - du ziehst 140A also 35A pro ESC - bist Du wahnsinnig :?: :!:
      -> Mein Vertrauen, dass die EzESCs mehr ab können und auch das 120A geratete v2 PDB der Vortex mehr ab kann, stammt von Sander Sassens (IRC) tchernobyl vortex build mit F60 2450kw Motoren bei Stock ESCs und DAL5x4.5x3HBN Props.
      Habe ihn auf fpvlab gefragt was das ding so zieht und er meinte 180A und dass die ESCs das locker abkönnen. Jetzt bin ich zwar eher der Meinung er wollte Ersatz PDBs verkaufen - aber nein ich bin nicht grundsätzlich verrückt :D

      2. 2205er Motoren auf 6" Props sind überfordert :!:
      -> ja vermutlich aber ich kann nicht schonwieder neue Motoren kaufen!! :/

      3. Die 45er haben zuviel Pitch
      -> jep aber 30er erfüllen vermutlich nicht meinen Anspruch nach nem Raketencruiser, und ich hab einfach nen Haufen 45er rumliegen die weg müssen. Aber ja vielleicht order ich mal ein paar 6040er.


      Hier noch das Blackbox Log:
      dl.dropboxusercontent.com/u/53…log_2016-12-07_160204.TXT


      PIDs (siehe Log)
      H pidController:1H rollPID:35,35,15H pitchPID:35,35,15H yawPID:35,35,20

      Hoffe jemand hat für mich einen Ansatz in welche Richtung ich tunen kann. :)