Omnibus AIO F4: XSR Hack für VFAS Telemetry zur Taranis

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • moscher schrieb:

      Bei meinem benutzen UART3 hab ich
      MSP aus, 115200
      Serial RX aus
      Telemetrie Output auf smartport, Auto
      Sensor Input Disabled, Auto
      Blackbox aus, 115200
      das wars

      Empänger muss mit funke gebunden sein, und im receiver tab müssen Knüppel Stellungen angezeigt werden.
      Ja, hab ich alles zich mal gemacht. Empfänger neu gebunden. Neues Modell in der Taranis angelegt. Diverse BF Versionen (3.0.1, RC4 und RC5) getestet. Sogar noch mal ein anderes Kabel benutzt und angelötet. Es kommen einfach keine Werte wenn ich auf Sensorsuche gehe! Irgendwo ist da der Wurm drin. Aber wo versteckt er sich?
      ╠══ Neueste FPV Teile »»» KLICK ══╣ ¤ ╠══ FPV Schnäppchen »»» KLICK ══╣
    • Riffer schrieb:

      Wenn du absolut keine Werte bekommst, versuche das Ganze mal ohne Kabel am SPort, denn mindestens 2 Werte müsste auch der X4R-SB schon von Alleine von sich geben, einer ist die Spannung des RX selbst.
      Ja, das hab ich auch gerade überlegt das der X4R ja von Hause aus schon ein paar wenige Werte übermitteln müsste. Aber selbst die kommen ja nicht an an der Funke.

      Das Kabel hängt allerdings nicht am seitlichen Smartport des X4R sondern ist ja auf Grund der invertierung auf der Rückseite an solch einen kleinen Lötpunkt angebracht. Aber ich entfern das Kabel jetzt mal und versuche das mal.



      Riffer schrieb:

      Alle Telemetrie-Sensoren in der Funke vorher einmal löschen.
      Da ich ja noch keine Sensoren drin habe bei dem Modell kann ich da auch noch nichts löschen. Oder meintest Du auch bei anderen Modellen die Sensoren löschen? Weil ich hatte den Empfänger vorher bei einem anderen Copter in Benutzung.
      ╠══ Neueste FPV Teile »»» KLICK ══╣ ¤ ╠══ FPV Schnäppchen »»» KLICK ══╣
    • fudashi schrieb:

      vllt noch ein f3 fc rumfliegen wo du den sport von deinem rx mal grundsätzlich testen kannst?
      Nein, leider kein F3. Aber hab ihn direkt aus meinem älteren Quad mit einer F1 Naze32 genommen. Da lief ja noch alles inkl. Telemetrie.

      Riffer schrieb:

      Nur die Sensoren beim Modell löschen. Hast du beim Binden auf eine neue Modell Nummer geachtet?
      Du meinst die Modell Match Nr in den Modell Einstellungen?
      Falls ja, ist definitiv eine andere. Die wird ja fortlaufend vergeben. Für meinen alten Quad wo der X4R drauf war ist die Nummer 01 eingetragen., Für mein neues Modell ist es die 06.
      ╠══ Neueste FPV Teile »»» KLICK ══╣ ¤ ╠══ FPV Schnäppchen »»» KLICK ══╣
    • Ok, Problem gefunden. Ich schein da an dem X4R irgendwas gegrillt zu haben beim anlöten des Kabels auf der Rückseite. Bin mir zwar nicht bewusst da länger als nötig auf dem Lötpunkt gewesen zu sein, aber es ist ja tatsächlich nur die Telemetrie die nicht mehr funzt. Alles andere geht noch.

      Hatte eben noch einen alten X4R wo mir mal eine Antennenbuchse abgerissen ist ausgekramt und diesen angelötet. Und da kamen die Werte sofort rein gepurzelt in die Taranis.

      Ohne Kabel waren es so wie es sein soll die 4 Standardwerte: SWR, RSSI, RxBt, A2

      Und mit Kabel die 15 erhofften Werte: AccY, AccZ, Tmp1, A4, VFAS, Curr, Alt, A2, Fuel, VSpd, Hdg, AccX, SWR, RSSI, RxBt

      Nun heisst es wohl einen neuen X4R bestellen wenn ich Telemetrie haben möchte... ||
      ╠══ Neueste FPV Teile »»» KLICK ══╣ ¤ ╠══ FPV Schnäppchen »»» KLICK ══╣
    • fudashi schrieb:

      also wenn der noch geht gönn dir doch eine Buchse und versuch dein Glück...
      Würd ich sogar machen wenn ich die Preise in den deutschen Shops sehe.
      Aber es geht ja gar nicht um die Buchse am X4R sondern um diesen Lötpunkt auf der Rückseite. Die Buchse benutzt man ja gar nicht in dem Fall.
      ╠══ Neueste FPV Teile »»» KLICK ══╣ ¤ ╠══ FPV Schnäppchen »»» KLICK ══╣
    • fudashi schrieb:

      Im letzten Post sprach ich von deinem alten X4R mit der abgerissen Antennenbuchse. Letzte kann man mit Lupe und ruhigen Händen sicher wieder erneuern.
      Ah, ok. Ja, nee da war nix mehr zu machen. Liegt bereits im Mülleimer das Teil. Denn zusätzlich war auch der Bind Button defekt. Hätte ich eh nicht neu binden können.

      EDIT: Ich versuch jetzt mal dieses rechteckige Teil vom einen Rx auf den anderen zu transferieren. Hab ja nix zu verlieren. Mal schauen ob diese OP gelingt. :D
      ╠══ Neueste FPV Teile »»» KLICK ══╣ ¤ ╠══ FPV Schnäppchen »»» KLICK ══╣

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von MrSmith ()

    • moscher schrieb:


      Vieles ist auch quatsch Tmp1 schwankt z.b zwischen 10001 und 30001 °C das lässt sich bestimmt nicht kalibieren.

      Wo ich das gerade sehe (auf der Suche nach Wissen über den F4 Omnibus) - Die Werte sind in der Tat sinnvoll.
      Bei der SmartPort-Telemetrie überträgt Cleanflight/Betaflight/iNav (weil die alle den gleichen Code teilen) verschiedene Informationen kombiniert in Tmp1 und Tmp2:

      Cleanflight.md schrieb:


      Tmp1 : actual flight mode, sent as 4 digits. Number is sent as (1)1234. Please ignore the leading 1, it is just there to ensure the number as always 5 digits (the 1 + 4 digits of actual data) the numbers are aditives (for example, if first digit after the leading 1 is 6, it means GPS Home and Headfree are both active) :
      1. 1 is GPS Hold, 2 is GPS Home, 4 is Headfree
      2. 1 is mag enabled, 2 is baro enabled, 4 is sonar enabled
      3. 1 is angle, 2 is horizon, 4 is passthrough
      4. 1 is ok to arm, 2 is arming is prevented, 4 is armed
      Tmp2 : GPS lock status, Number is sent as 1234, the numbers are aditives :
      1. 1 is GPS Fix, 2 is GPS Home fix
      2. not used
      3. not used
      4. number of sats

      Ich flieg' Kopter :D und Flächen-Modelle! :thumbup: Aber keine Drohnen... :thumbdown:
    • Hi,

      verstehe ich das richtig, so wie es in SteBo's Grafik zu sehen ist: die OSD-Daten, Akku-Strom und Höhe, werden dadurch über den FPV-Sender an meine Brille übertragen und werden dort sichtbar, daß das gelbe Signalkabel durch VideoIN und VideoOUT quasi nur unterbrochen wird?
      Und noch eine Frage: ich möchte mir für meine F4 Pro nicht extra einen 3-pol-Stecker für den LED-Strip besorgen, Kann ich das Signalkabel für den LED-Strip unter BF 3.1.7 an PWM6 anschliessen? 5V und GND dann von irgendwo her?

      Danke & Grüße
      ypse
    • ypse schrieb:

      verstehe ich das richtig, so wie es in SteBo's Grafik zu sehen ist: die OSD-Daten, Akku-Strom und Höhe, werden dadurch über den FPV-Sender an meine Brille übertragen und werden dort sichtbar, daß das gelbe Signalkabel durch VideoIN und VideoOUT quasi nur unterbrochen wird?
      Ja, verstehst Du richtig. Das OSD wird quasi zwischen geschaltet.

      ypse schrieb:

      Kann ich das Signalkabel für den LED-Strip unter BF 3.1.7 an PWM6 anschliessen? 5V und GND dann von irgendwo her?
      Nicht können sondern müssen. Wenn Du programmierbare LEDs hast muss das Signalkabel an PWM6 angeschlossen werden. Wo Du die Spannung für die LEDs her nimmst spielt keine Rolle. Ich hab Plus und Minus an die Rückseite der LED Buchse gelötet. Also an die Kontakte. Funzt super und so hab ich nur minimale Kabelwege für die LED am Heck.
      ╠══ Neueste FPV Teile »»» KLICK ══╣ ¤ ╠══ FPV Schnäppchen »»» KLICK ══╣