Omnibus F4 pro v2 Probleme: OSD fonts, LED mapping, full chip erase

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Omnibus F4 pro v2 Probleme: OSD fonts, LED mapping, full chip erase

      Hallo,

      ich habe ein Problem mit dem Omnibus F4 pro v2. Jedes mal wenn ich die OSD fonts ändern will, startet der FC neu und speichert die Änderung nicht.
      Beim aller ersten mal hat es funktioniert, danach nie wieder. Habe diverse Betaflight builds getestet. Aktuell bin ich bei 3.1.6.
      Vielleicht hängt es damit zusammen, dass der full chip erase bei mir nicht funktioniert? Hat da vielleicht jmd einen Hinweis, was ich falsch mache?

      Noch eine kurze Frage: Wo sind die LEDs hingemappt? PWM6 scheint nicht zu klappen...

      Viele Grüße,

      Luc
    • Luc schrieb:

      ich habe ein Problem mit dem Omnibus F4 pro v2. Jedes mal wenn ich die OSD fonts ändern will, startet der FC neu und speichert die Änderung nicht.
      Mit dem Full Chip Erase hat das nichts zu tun. Aber auch der sollte problemlos funktionieren. Ich upgrade meinen F4 Pro immer auf diese Art,

      An welcher Stelle genau startet der FC denn neu? Du wählst im Fontmanager die Schriftart aus und dann direkt? Oder kannst Du noch auf Upload klicken?

      Luc schrieb:

      Noch eine kurze Frage: Wo sind die LEDs hingemappt? PWM6 scheint nicht zu klappen...
      Beim Pro ist es definitiv PWM6 und der funzt auch. Habe selbst auch LEDs dort dran und läuft ohne Probleme. Beim normalen Omnibus F4 ist es PWM5.
      ╠══ Neueste FPV Teile »»» KLICK ══╣ ¤ ╠══ FPV Schnäppchen »»» KLICK ══╣
    • Wenn ich full chip erase auswähle, dann läuft der Balken durch (erasing...) und danach wechselt er in flashing.. und bleibt dort ewig hängen. Muss dann full chip erase ausmachen und ohne nochmal flashen. Hatte das Problem mit einem SPracing F3 evo schonmal. Nen Xracer zu löschen ist hingegen kein Problem..

      Der FC startet neu sobald er mit dem font Upload fertig ist. Danach ist aber leider alles beim alten :( Wie gesagt es hat genau einmal funktioniert :D

      Oh, dann kann es sein, dass ich einfach eine falsche 5V Quelle ausgesucht habe (PWM pins Mitte). Hab ein 4in1 ESC und deswegen vielleicht keine 5V dort liegen. Wo hast du VCC von den LEDs angeschlossen? Hast du das aktuelle Betaflight drauf?
    • Habe nach wie vor das gleiche Problem, wie hier bereits beschrieben: fpv-racing-forum.de/thread/258…9&highlight=osd#post37629
      Ich kann weder an einem Omnibus F4 noch an einem Omnibus F3 die Schrift ändern. Egal ob mit oder ohne Akku, nach dem Upload startet der FC neu. Wenn ich vorher oder ohne Upload zu klicken auf Save klicke, ist die Schrift zwar in der Vorschau geändert, aber wenn ich dann den OSD Reiter verlasse, ist es beim nächsten Aufrufen wieder auf Standard Schrift.
      Viele Grüße!
      Alex
    • Luc schrieb:

      Wo hast du VCC von den LEDs angeschlossen?
      Spielt keine Rolle wo man das anschliesst. Hauptsache es sind 5volt. Ich hab es direkt am LED Anschluss dran. Dort kommen 5v raus. Laut Zeichnung ist das J1. Hab allerdings keinen Stecker verwendet sondern direkt ran gelötet.

      Luc schrieb:

      Hast du das aktuelle Betaflight drauf?
      Ja, hab ich. Hat aber mit der Version nichts zu tun. War auch bei den älteren Versionen der letzten Wochen/Monate der PWM6 für die LED Steuerung.

      SignalSpirit schrieb:

      Das mit dem Full Chip Erase scheint eine allgemeine Krankheit des Omnibus F4 pro zu sein.
      Davon les ich jetzt das erste Mal. Und ich verfolge die Omnibus Threads auf RCgroups sehr aufmerksam.
      Hatte damit wie gesagt bislang keine Probleme und ich flash ihn immer mit Full Chip Erase. Vielleicht mal die Baudrate etwas runter stellen?
      ╠══ Neueste FPV Teile »»» KLICK ══╣ ¤ ╠══ FPV Schnäppchen »»» KLICK ══╣
    • SignalSpirit schrieb:

      Ich hatte da das Problem gepostet und die Antwort von Teralift kam ruckzuck. Anscheinend kennt er das verhalten.
      Ah, ok. Wo hast Du Deinen F4 Pro denn gekauft?

      SignalSpirit schrieb:

      Ist Teralift nicht sogar vom Hersteller des OmnibusPro?
      Die Frage hat er bislang ignoriert. Aber so engagiert wie er zu den Omnibus Themen den ganzen Tag lang schreibt kann man wohl stark davon ausgehen das es nicht nur Nächstenliebe ist.
      ╠══ Neueste FPV Teile »»» KLICK ══╣ ¤ ╠══ FPV Schnäppchen »»» KLICK ══╣
    • SignalSpirit schrieb:

      Bei MyAirBot. Ich bin aber nicht unzufrieden, sondern absolut begeistert.
      Ah, ok. Dann ist es ja auf jeden Fall ein Original. Beim nächsten Mal probier ruhig mal eine niedrigere Baudrate. Sollte eigentlich problemlos funzen mit dem Full Chip Erase.

      Bin ebenfalls recht begeistert so wie Du auch. Meiner Meinung der beste FC zur Zeit. Nicht ganz preiswert, aber es lohnt sich.
      Und wer auf Barometer und Current Sensor verzichten kann holt sich halt den normalen. Denn den gibts ja mittlerweile für knapp 20 EUR auch als Clone bei BG. Den hab ich erst vor ein paar Tagen für mein Zweitcopter geholt. >>> LINK
      ╠══ Neueste FPV Teile »»» KLICK ══╣ ¤ ╠══ FPV Schnäppchen »»» KLICK ══╣
    • Hab vorhin mal meinen Omnibus F4 Pro von BF 3.1.6 auf BF 3.2 RC3 geupdated und mich gewundert warum meine LEDs auf einmal nicht mehr funktioniert haben. Den ganzen Copter zerlegt, weil ich dachte da hat sich ein Kabel gelöst aber nix. Dann mal auf BF 3.1.7 gegangen und auch nix. Dann wieder 3.1.6 und et voila sie gingen wieder. Also gegoogelt und bei Github dies hier entdeckt:

      github.com/betaflight/betaflight/wiki/Board---OMNIBUSF4

      Das heisst ab 3.1.7 schliesst man die LEDs nicht mehr an PWM6 an sondern an den dafür vorgesehenen LED Port. Leider hab ich dafür im Obsession keinen Platz da hinten noch einen Stecker zu platzieren. Mein LED Signalkabel bleibt also wo es ist an PWM6. Daher hab ich die beiden einfach über resource getauscht und es funzt wieder.

      Wem es so geht wie mir und sein Kabel auch lieber an PWM6 lassen möchte muss nur folgendes in die CLI eingeben:

      resource MOTOR 6 none
      resource LED_STRIP 1 A08
      resource MOTOR 6 B06
      save

      Hab das mal mit in diesen Thread gepackt weil ja hier im Titel auch "Omnibus F4 Pro" und "LED mapping" steht. :)
      ╠══ Neueste FPV Teile »»» KLICK ══╣ ¤ ╠══ FPV Schnäppchen »»» KLICK ══╣