Naze32 Rev5 mit micro minimOSD und Cleanflight/Betaflight

    • Naze32 Rev5 mit micro minimOSD und Cleanflight/Betaflight

      An das Naze32 Rev5 Board (Abusemark) habe ich das micro minimOSD an den RX und TX Port (Anschlusspins für die serielle Kommunikation) angeschlossen. Klappt auch soweit prima. Das Board sendet Daten an das OSD.

      Wenn ich nun das Board via USB Kabel an den PC anschließe, wird dies auch soweit korrekt in Cleanflight/Betaflight erkannt. Versuche ich nun eine Verbindung zwischen Kopter und Software herzustellen kommt ein TimeOut. Erst wenn ich das Kabel vom OSD am RX Port des Naze32 abziehe, klappt der connect. Ist das normal, oder muss ich noch eine Einstellung in der Config von Cleanflight/Betaflight ändern?
    • Du kannst natürlich auch das OSD an UART2 anschließen, dann verwendest du hald nicht die extra ausgeführten RXTX-Leitungen.

      Hier sind beide Anschlussvarianten aufgezeichnet:
      Alien 5" / ZMX 2206-2300 / KISS 24A / 5x4x3 / TBS PNP50 / KISS FC / X4R-SB / HS1177 / Unify Pro
      Orca / ZMX 2206-2522 / Cicada 30A / DAL 5x4.5x3 V2 / HUBOSD / Raceflight Revolt / X4R-SB / HS1190 / Unify Pro V2
    • luftKNIPSER schrieb:

      Auch eine Lösung, guter Hinweis für den nächsten Kopter, dann kann man es schnell und einfach abziehen.

      Habe festgestellt, dass man mit cleanflight/Betaflight dennoch per USB Kabel (bei angeschlossenem OSD) auf das Naze32 Rev5 zugreifen kann. Dies geht nur wenn kein LIPO am Kopter ist. Dann reichen die 5V des USB Ports gerade um das Bord zu betreiben.
      Das ist mir auch aufgefallen, aber das liegt denke ich nicht an der Leistung des USB-Ports sondern an der Software. Wenn du den unversorgten Naze direkt an den USB anhängst, springt er gleich in den "USB-Kommunikationsmodus" rein. Dann funktioniert es auch trotz angeschlossenem OSD. Wenn du ohne USB Strom zuführst (= Akku ansteckst) fährt der Naze normal hoch und sendet am UART die MSP-Daten ans OSD. Manchmal (wenn "restartet" wird) werden die Einstellungen im Cleanflight aber nicht übernommen, weshalb die alternative Anschlussmöglichkeit mMn empfehlenswerter ist.
      Alien 5" / ZMX 2206-2300 / KISS 24A / 5x4x3 / TBS PNP50 / KISS FC / X4R-SB / HS1177 / Unify Pro
      Orca / ZMX 2206-2522 / Cicada 30A / DAL 5x4.5x3 V2 / HUBOSD / Raceflight Revolt / X4R-SB / HS1190 / Unify Pro V2
    • Ich stehe grade genau vor dem selben Problem und habe das naze und osd auf nem pdb gelötet! Alternative geht glaube ich nicht da ich Sbus nutze... Meine Frage wäre jetzt kann ich das osd irgendwie per dipschalter komplett ab und aus machen sodass ich mit Lipo wieder USB Zugriff habe?

      Ich dachte da an einen Mini dipschalter den ich an eins der osd Beinchen oder so löte?

      Wenn das gehen sollte an welches Beinchen müssten das machen?
      Würde gerne mit Lipo den USB Anschluss nutzen damit ich wieder Zugriff auf die escs habe über blhelisuite!

      Also pin 4 ist Sbus bei mir und pin 5 rgb leds!

      Vielleicht hat ja jemand eine idee...

      Mit freundlichen Grüßen
      Dennis
    • Hey,

      hier mal nen Link. Da geht es eigentlich um Naze32 rev6 und Sbus bzw. Smart Port Telemetrie. Im Verlauf des Threads diskutieren die User aber auch das Problem mit OSD bzw. LED-Strips, da für den Smart-Port auf der Nazel Channel 5+6 sprich die sonstigen RX/TX (glaube Uart2) benutzt werden.

      rcgroups.com/forums/showthread.php?t=2573800

      vielleicht hilft dir das ja etwas.

      Gruß
    • Ja ich überlege auch was ich machen soll. In dem Link gehts ja um Smart-Port, so dass RSSI ersetzt wird. Du kannst natürlich darauf verzichten. wenn du nur Sbus verwendest. Ich habe derzeit kein OSD und bekomme meine Telemtriedaten über den Receiver Smart Port. RSSI sendet er selbst und Batterie kommt vom Voltage-Sensor per Smart-Port an den Receiver.

      Nach dem Link könnte ich also auf den Voltage-Sensor verzichten und V-Bat nutzen, aber dann eben kein OSD, soweit ich das jdnf verstehe.