Probleme mit Micro Minimosd / Betaflight

    • Probleme mit Micro Minimosd / Betaflight

      Neu

      Guten Abend,

      Ich bin neu hier im Forum und weiß Gar nicht genau wo ich anfangen soll mein Problem zu beschreiben.

      Ich habe vor circa einer Woche meinen ersten Quad fertig zusammengebaut und er funktioniert wunderbar, nur die Verkabelung war hier und da etwas hässlich und ganz allgemein wollte ich das Ding nochmal durchdachter aufbauen.
      Gesagt getan habe ich den Quad zerlegt und beim erneuten Bau auch versucht ein Micro Minimosd zu integrieren. Und hier liegt auch der Hund begraben.
      Beim Nachfolgenden glaube ich dass ich das getan habe, ganz sicher bin ich mir nicht.

      Ich habe einer Anleitung folgend MWOSD 1.7 geflasht und die Standalone GUI von Virtual Pilot erworben. Da ich das OSD mit dem GUI verbinden konnte (write/read) wollte ich es erstmal dabei belassen und später die Konfiguration per Passthrough vornehmen.
      Jetzt habe ich also das OSD im Kopter verbaut (UART2 an einem SP Racing F3) und der Quad tut soweit was er soll. Allerdings bekomme ich im MWOSD GUI keine Verbindung mehr (CLI error oder so). In Betaflight habe ich Serialpassthrough 1 (für UART2) schon eingegeben, bekomme dort die Meldung dass der Port frei sei.

      Und jetzt kommt das was ich am allerwenigsten verstehe.

      Ich Betaflight unter Konfiguration kann ich OSDaktivieren und es dann im Reiter “OSD“ einstellen. Auch damit würde ich mich zufrieden geben, auch wenn ich nicht verstehe warum das geht, micro minimosd ist doch gar kein Betaflight OSD oder?
      Aber hier ist der hinderliche Punkt dass der Font Manager gänzlich fehlt, was ein Nutzen von zB. dem künstlichen Horizont unmöglich macht, da anstatt von Bindestrichen irgendwelchen wirren zeichen verwendet werden.

      Also ganz steif ich noch nicht durch und bin dankbar für jede Hilfe

      Bei Rückfragen bin ich selbstverständlich da

      Beste Grüße
      Mahi
    • Neu

      So nett es ausehen mag: Die Betaflight OSD Konfiguration hilft Dir nicht weiter. Es bedeutet nur, dass Du das Feature in dem Build für Dein Board aktivieren kannst. Aber passieren wird nix, weil kein Betaflight OSD da ist. Das wird technisch anders angesprochen als ein MinimOSD.

      Der Serialpassthrough sollte eigentlich funktionieren. Welches Kommando hast Du genau eingegeben? - Passen die Geschwindigkeiten?
      Ich habe bei meinem einzigen MinimOSD Build die Serielle auf einen Pfostenstecker gepackt. Ich verbinde da immer direkt. Wenn die Pfostenstecker im Flug abrutschen sollten, wäre nur das OSD tot. Davon stürzt man nicht ab.
    • Neu

      Hey

      Schon mal danke für die Antwort. Das mit dem Betaflight OSD ist ja das kuriose. Ich kann das OSD nämlich aus irgendeinem Grund durchaus über Betaflight konfigurieren. Nur der Font passt nicht, so das zum Beispiel die Bindestriche vom künstlichen Horizont so komische Zeichen mit einem “G“ sind. Das Feature an sich funktioniert aber. Genauso wie der Flighttimer etc. Hab die einzelnen Funktionen auch mal aus und wieder angestellt um sicher zugehen dass es tatsächlich von Betaflight und nicht von MWOSD kommt.

      Wie schon gesagt ist im OSD Reiter in Betaflight der Font Manager Button nicht da.

      In der Kommandokonsole habe ich “serialpassthrough 1“ eingegeben, hab aber auch schon 2 ausprobiert, ohne Veränderung.
    • Neu

      Ich hab mich auch mal mit nem micro minimosd herumgeschlagen, damit tust du dir keinen Gefallen. Das Ding lässt sich kaum sauber verbauen.

      Ich würde dir nen omnibus F3 oder F4 empfehlen. Die bekommst du als brauchbaren clone unter 20€...
      Ausschließlich in der Mitte von Nix zu schweben macht mich depressiv!
      ...meine Rechtschreibprüfung funktioniert zum Glück nur bei kurzen Wörtern. Korrekte Wörter werden da immer durch unsinnige andere ersetzt.
    • Neu

      Hi,

      Ja einfachere alternativen hab ich schon gefunden, es wird wohl was in Richtung Matek F405 CTR werden.

      Aber da ich ja erst mit dem Hobby angefangen habe und durchaus gewillt bin mich mehr in der Materie einzufinden und eben nicht nur darauf aus bin möglichst schnell und stressfrei zu fliegen wäre es schon schön wenn ich / wir herausfinde worans da scheitert.
      Wenn ich mich an google versuche komme ich mir ohnehin vor wie der einzige Mensch auf der Welt mit besagtem Problem, ich finde rein gar nichts zu oben beschriebener Situation...

      Grüße
    • Neu

      Dann wäre mein Tipp (falls englische Sprache für dich kein Problem ist) mal im betaflight slack channel direkt zu fragen.
      Ich kann dir entweder an ne Mail address n invite schicken oder mal warten ob die mir antworten ob es ne neue self-invite Adresse gibt.
      Ausschließlich in der Mitte von Nix zu schweben macht mich depressiv!
      ...meine Rechtschreibprüfung funktioniert zum Glück nur bei kurzen Wörtern. Korrekte Wörter werden da immer durch unsinnige andere ersetzt.
    • Neu

      Stefan73 schrieb:

      Probier mal Serialpassthrough mit passender Baudrate für Dein MinimOSD; zB.
      serialpassthrough 1 57600

      P.S.: Font Upload Probleme bei MinimOSD sind oft ein Spannungsproblem. Der MinimOSD Code geht in den ATMega 328. Die Font in den OSD Chip und der ist etwas "picky".
      Ganz vergessen, die Baudrate hab ich mit eingegeben.
      Müsste dann nicht aber wenigstens der Font Manager da sein? Ich komm ja nicht mal zum Versuch den Font zu ändern.

      Und das größte Mysterium bleibt anscheinend warum das Micro Minimosd hier als Betaflight OSD zu funktionieren scheint...