Anfänger Zweitcopter - Suche einen geeigneten Frame (ggf. später auch noch Komponenten)

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Überall wo RX / TX dran steht ist ein UART
      Wo SBus / Spektrum / PPM / Sumd dran steht ist ein UART

      UART 3 auf deinem Link, dort wo das GPS angeschlossen ist

      Interner Speicher / SD Karte für Blackbox ist dann wichtig wenn du das PID Tuning nicht hinbekommst oder sonst was ist. Aus den Blackbox Daten können Fehler / Einstellungen optimiert werden.

      Runcam Split = FPV Cam die nebenher noch in HD Filmen kann und auf eine SD Karte aufnimmt
      m.banggood.com/RunCam-Split-2-…2SDgeqEAAYASAAEgKbYPD_BwE
    • cluedo schrieb:

      Überall wo RX / TX dran steht ist ein UART
      Wo SBus / Spektrum / PPM / Sumd dran steht ist ein UART

      UART 3 auf deinem Link, dort wo das GPS angeschlossen ist
      Danke für die Zusammenfassung. Nun zähle ich aber 8 (rote Kästchen) :|
      Oder ist eine RX/TX Kompo ein UART? In dem Fall wären es 5, wobei dem RC und dem GPS jeweils sein Partner fehlen würde. Wenn zusammengehören sollten wären 4 UARTS.
      Mein Buildlog für andere Einsteiger: Finale Zusammenstellung und Start des Buildlogs (Teilweise kamen noch weitere Komponenten im Laufe des Buildlogs hinzu.)
    • RX und TX ist immer ein UART
      de.m.wikipedia.org/wiki/Univer…nous_Receiver_Transmitter

      SDA und SCL kannst du nur für Kompass verwenden
      Das ist ein I2C Anschluss
      de.m.wikipedia.org/wiki/I%C2%B2C

      Beim UART1 ist wohl nur der RX herausgeführt, hier mit RC (Radio Control) beschriftet
      Der TX des UART4 ist an zwei Stellen auf dem FC, du kannst den aber nur einmal benutzen.
      UART2 scheint mir mit Fcam beschriftet, bin aber nicht sicher, weiß auch nicht ob das ein RX oder TX ist. Müsste man mal vom Beinchen des Chip aus messen.
    • cluedo schrieb:

      Beim UART1 ist wohl nur der RX herausgeführt, hier mit RC (Radio Control) beschriftet
      Der TX des UART4 ist an zwei Stellen auf dem FC, du kannst den aber nur einmal benutzen.
      UART2 scheint mir mit Fcam beschriftet, bin aber nicht sicher, weiß auch nicht ob das ein RX oder TX ist. Müsste man mal vom Beinchen des Chip aus messen.
      Dickes danke dir für die Erklärungen! Das hat jetzt sehr geholfen.

      UART 1 leuchtet mir ein
      UART 2 nicht so ganz - ist das nicht die Kombo RX2/TX2?
      UART 4: Ich hab kräftig abgesucht finde RX4/TX4 nur an einer Stelle (Sofern die Annahme stimmt, dass UARTz = TXz/RXz)
      Könnte FCam dann evtl. der doppelte UART, also UART4 sein?

      Für mich zeichnet sich grad ab, dass der DALRC F405 ausreichend UARTs besitzt.
      Mein Buildlog für andere Einsteiger: Finale Zusammenstellung und Start des Buildlogs (Teilweise kamen noch weitere Komponenten im Laufe des Buildlogs hinzu.)
    • bocholter schrieb:

      Ich hab welche von foxeer und runcam im Einsatz und bin mit allen ziemlich zufrieden.
      Hab auch viel gutes von der Micro sparrow 2 gehört.

      bocholter schrieb:

      Hier ist mal ein Vergleichsvideo auch inkl. micro eagle:
      Nachtrag zu den Cams:
      Ich hab mir das video angeschaut. Die Eagle ist definitiv die beste. Leider hat er die Arrow v2 nicht getestet. Ich versuche hier noch möglichst "günstig" weg zu kommen. Wenn ich mir meine aktuelle Cam anschaue, dann bin ich froh, nicht mehr investiert zu haben, da die doch einige Schläge auf die Linse abbekommen hat und das Bild auch deutlich gelitten hat.

      Welche Cams hast du denn genau im Einsatz? Auch Micros?

      Es gibt 2 Varianten der Sparrow 2: Einmal WDR und einmal v2 mit Super-WDR.
      EDIT:
      nachdem ich mir nun dieses Video hier angesehen habe scheint die Runcam Micro Sparrow (v1) doch etwas vor der Foxeer Arrow Micro v2 zu liegen

      Sieht momentan für mich nach einem Kauf der Runcam Micro Sparrow v1 oder v2 aus. Liegt auch preislich attraktiv bei unter 20€ bzw. etwas drüber.
      Mein Buildlog für andere Einsteiger: Finale Zusammenstellung und Start des Buildlogs (Teilweise kamen noch weitere Komponenten im Laufe des Buildlogs hinzu.)

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Rey ()

    • Bin mit der Micro Eagle nicht so zufrieden. Sehr viel "Geschimmer". Wenn man die Schärfe runterdreht, um das zu bekämpfen, fehlt einem genau das - Schärfe. Die micro sparrow hat glaube ich ähnliche Technik wie die Foxeer Predators und sollte damit gut sein.

      Zum DAL FC: den habe ich ja verbaut. "FCam" ist nichts anderes als Camera Control und (meines Wissens) ist das kein UART. Speicher hat er onboard, man brauch also keinen externen SD-Schreiber (benutzt sowas wirklich jemand?).
      Da wo "RSSI/Sport" dran steht, ist das etwas irreführend. Der pin ist ein normaler UART ohne spezielle Funktion. Ist also auch nicht invertiert - Telemetrie also über Softserial am LED Pad, wenn man nichts an der Invertierung drehen möchte.
      Am Ende brauchst du wahrscheinlich nur zwei UARTs und das sind die für sbus und smartaudio. Bleibt also noch vieles ungenutzt.
    • Dillbriese schrieb:

      Telemetrie also über Softserial am LED Pad, wenn man nichts an der Invertierung drehen möchte.
      Dieses Invertierungsthema hatte ich beim ersten Copter schon nicht ganz verstanden und möchte es jetzt nachholen. Beschrieben wird es ja in dem Blog hier blog.seidel-philipp.de/betafli…-invertieren-ohne-loeten/
      Ich habe es nun zusammen mit deinem Beitrag so verstanden, dass ich den S-Port auf das LED Pad bringe und dann dort via Softwareeintragung invertieren kann. Korrekt?
      Nun die Anschlussfrage: Wo befindet sich das LED Pad? Ich habe das Schema des FCs nach einem solchen Anschluss erfolglos abgesucht.

      Soweit steht ja fast alles - bei der Kamera bin ich mir nun auch recht sicher - fehlen noch die Motoren. Wenn ich alles heute Abend bestelle, kann ich ggf. sogar schon kommende Woche basteln - Nice.

      EDIT / Nachtrag:
      Noch zur Pinbelegung des DALRC Flightcontrollers - ich bin hier auf die Übersicht gestoßen - 5 UARTs sollten also vorhanden sein und alle TX/RX sollten nach außen geführt sein: "All uarts have pad on board"
      github.com/betaflight/betaflig…/Board%20-%20DALRCF405.md

      Besonders Interessant ist die folgende Tabelle github.com/betaflight/betaflig…l-uarts-have-pad-on-board

      Dort steht in Zeile 1:

      Value | Identifier | RX | TX | Notes
      1 | USART1 | PB7 | PA9 | PB7 FOR SBUS IN(inverter build in)

      Somit muss ich nichts weiter invertieren, sondern "nur" den SmartPort an den UART1 anschließen, oder?

      Wobei mir nicht klar ist wie ich den UART1 auf dem FC identifizieren kann.

      Was mich noch irritiert ist, dass ich auf dem realen FC die Bezeichnungen im Stil von z.B. RX4/TX4 sehe - in der Tabelle aber die Ports mit ihren Nummern (z.B. PA0/PA1 in Zeile 4) angegeben werden.
      Meine Vermutung: In der Tabelle stehen die Softwareausgänge (Interne Ports) welche via Ressourcen-Mapping auf die Hardware-Ausgänge, wie z.B. RX4/TX4 gemappt werden können. Hoffentlich hab ich das so richtig verstanden.
      Mein Buildlog für andere Einsteiger: Finale Zusammenstellung und Start des Buildlogs (Teilweise kamen noch weitere Komponenten im Laufe des Buildlogs hinzu.)

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Rey ()

    • Sieht man doch an dem Bild, das man da nichts machen muss. S-Port an das RSSI Pad und TX4 einstellen. Uart 1 erkennt man doch, da steht doch "RC" (radio controll) = Rx1. Ist wie mit VCC/Vbat, RC = Sbus.
      Wenn man durchzählt hat man 5 Uarts, Cam Control und SA sind demnach keine Uarts.

      Auf den Rest werde ich nicht weiter eingehen, du machst dir viel zu viele Gedanken ;)

      Dillbriese schrieb:

      Bin mit der Micro Eagle nicht so zufrieden. Sehr viel "Geschimmer".
      Da hat er leider recht, die Micro Eagle ist wirklich nicht besonders gut. Da mag ich lieber meine Micro Swift, bin auch mehr Fan von Ccd.
    • FPV Racer 2017 schrieb:

      du machst dir viel zu viele Gedanken
      Das sehe ich offen gesagt anders. Mir geht es darum das Thema richtig zu durchdringen und die relevanten Angaben aus den Schaltbildern bzw. dem Platinenabbild eines FCs zu erkennen, ohne auf die Beispielbilder, oder eben Hinweise aus dem Forum angewiesen zu sein. Einfach stumpf zusammenlöten reicht mir nicht (mehr). Da die Informationen leider nicht irgendwo sauber gesammelt nachzulesen sind muss ich das ganze Verständnis aus Bruchstücken und 1.000 Fragen zusammensetzen. Dennoch merke ich, dass hier irgendwo die Grenze aufgrund verfügbarem Wissen erreicht ist :).

      FPV Racer 2017 schrieb:

      S-Port an das RSSI Pad und TX4 einstellen.
      Stimmt schon - laut dem Schembild des FCs muss SmartPort an RSSI gelötet werden und alles ist gut - allerdings steht dies im Widerspruch zu dem Hinweis von @Dillbriese (der den FC ja im Einsatz hat): "Da wo "RSSI/Sport" dran steht, ist das etwas irreführend. Der pin ist ein normaler UART ohne spezielle Funktion. Ist also auch nicht invertiert - Telemetrie also über Softserial am LED Pad, wenn man nichts an der Invertierung drehen möchte."

      Dickes Danke jedenfalls nochmal für den indirekten Hinweis, dass die UART Nummern aus dem Betaflight Screenshot mit den TX/RX Nummern auf dem Board übereinstimmen. Das bringt mich wieder ein Stück weiter. Jetzt hab ich übrigens auch alle RX und TX Beschriftungen entdeckt - da sind mir welche durch die Lappen gegangen.

      ---
      Bezüglich Kamera steht nun (nach einigen Videoreviews) noch die Entscheidung zwischen der Micro Sparrow 2 https://www.banggood.com/Runcam-Micro-Sparrow-2-Super-WDR-OSD-700TVL-CMOS-FOV-150-Degree-2_1mm-43-FPV-Mini-Camera-NTSC-PAL-p-1271733.html?p=TK13077353551201611V&cur_warehouse=CN und der Micro Swift 2 https://www.banggood.com/RunCam-Micro-Swift-2-600TVL-2_1mm2_3mm-FOV-160145-Degree-13-CCD-FPV-Camera-with-Built-in-OSD-p-1179743.html?rmmds=search&cur_warehouse=CN aus

      ---
      Bei den Motoren bin ich grad richtung Amaxx unterwegs:
      Mein Buildlog für andere Einsteiger: Finale Zusammenstellung und Start des Buildlogs (Teilweise kamen noch weitere Komponenten im Laufe des Buildlogs hinzu.)
    • Der Aufbau hat nun lange auf sich warten lassen, da der ESC lange auf sich warten lies. Ich hab nun alles zusammengebaut und steh nun vor zwei Problemen, die ich nicht gelöst bekomme.

      Schema des FC siehe dalrcmodel.com/DALRC/uploads/a…7%89%8720180302122036.jpg
      Meine Verdrahtung siehe weiter oben.

      Problem 1) Es wird ein "schwarzes Bild" gesendet
      Verbinde ich das Videokabel von Kamera und VTX direkt miteinander funktioniert die Bildübertragung. Schalte ich aber den FC dazwischen (Cam -> FC -> VTX) ist das Videosignal schwarz.
      Der Video-Out Anschluss des FCs liefert kein Bild.
      Beim VRX bekomme ich einen Pegel angezeigt.

      Problem 2) Beim anstecken des Akkus piept der FC / ESC 1x. Die folgemelodie mit den 4 Tönen fehlt aber. Schließe ich dann anschließend noch das USB Kabel an, so ertönt die normale "Bott-Melodie".
      Muss ich doch noch die 5V anschließen?
      Der ESC liefert keine 5V_out, daher könnte ich ggf. eine Brücke vom 5V_out des FCs an 5V_in des FCs löten, aber das macht ja eigentlich garkeinen Sinn :)

      Kann es sein, dass hier noch was falsch verkabel ist?
      Mein Buildlog für andere Einsteiger: Finale Zusammenstellung und Start des Buildlogs (Teilweise kamen noch weitere Komponenten im Laufe des Buildlogs hinzu.)
    • Dillbriese schrieb:

      - Hast du BEIDE Lötbrücken zur Spannungsauswahl auf dem FC gesetzt?
      Ja - beide sind auf 9V gesetzt. (war schon so)

      Dillbriese schrieb:

      - Siehst du das OSD?
      Nein. In Betaflight Configurator war OSD erst deaktiviert, ich musste es aktivieren. Dennoch kommt kein Overlay. Spannungsmessung zwischen Video und GND ergibt 0 Volt.

      ---
      Fotos lade ich in die Dropbox hoch - hier müsste ich zu sehr verkleinern.
      1) dropbox.com/s/52aoebzll0q9a6n/20181021_104323.jpg?dl=0
      2) dropbox.com/s/9esps3xvf3a4h3q/20181021_104536.jpg?dl=0

      Noch eine Ergänzung: Der ESC 4in1 liefert dem FC am Eingang 16.4 Volt (Gemessen an Vcc, GND)
      Mein Buildlog für andere Einsteiger: Finale Zusammenstellung und Start des Buildlogs (Teilweise kamen noch weitere Komponenten im Laufe des Buildlogs hinzu.)
    • Ist da ein Kügelchen Lot auf den Beinen des OSDs?


      Ich würde außerdem Dinge wie FC und 4in1 immer mit irgendwas durchlötbarem einsprühen / pinseln, das vor ungewollten Kontakten und Feuchtigkeit schützt.

      Ansonsten sehe ich nicht, was das Problem ist, die Videoverkabelung sieht mir ok aus. Liegen denn auf den beiden Strompads jeweils die 9V an?
      Für die Kamera kannst du z.B. auch 5V vom vtx abgreifen. Mache ich grundsätzlich so.

      Ansonsten:
      - Das OSD-Kabel der Kamera hättest du an FCam löten können, dann könntest du CameraControl nutzen.
      - Hast du Smartport invertiert? Wenn nein, musst du das gelbe Kabel des Empfängers nochmal umlöten. Auf LED und dann SoftSerial.
      - Sieht vielleicht nur auf den Fotos so aus, aber der Hauptstromanschluss am ESC sieht mir aus, als wären die Lötstellen nicht komplett heiß und flüssig gewesen. Vielleicht nochmal mit ordentlich Power draufgehen und die richtig schön verschmelzen lassen.
    • Dillbriese schrieb:

      Ist da ein Kügelchen Lot auf den Beinen des OSDs?
      Ja, war tatsächlich so. Habe es entfernt, aber keine Besserung. hoffentlich ist nichts kaputt gegangen :/
      Ich hab nochmal experimentiert: Wenn ich den Copter aus lasse und die Brille auf RB4 stelle habe ich ein Ameisenbild. Schalte ich den Copter ein schlägt das Signal an der Brille voll aus und das Bild wird komplett schwarz.

      Dillbriese schrieb:

      Ich würde außerdem Dinge wie FC und 4in1 immer mit irgendwas durchlötbarem einsprühen / pinseln, das vor ungewollten Kontakten und Feuchtigkeit schützt.
      Gute Idee. Ich habe gestern schon einen FC beim Durchmessen und bei er Fehlersuche frittiert, weil ich versehtlich einen kurzschluss verursacht habe...
      Wie heißt da Zeug genau?

      Dillbriese schrieb:

      Liegen denn auf den beiden Strompads jeweils die 9V an?
      Ja, 9.34 Volt liegen an., so wie die Bürcke aktuell sitzt
      Setze ich die Lötbrücke auf 5V kommt nichts an.

      Interessant ist übrigens folgendes: Ich habe die Brücke für die Camera einmal versehentlich komplett geschlossen und dann kommt die Start-Melodie des ESCs! Allerdings liegen dann an 5V Out des FCs die 9.34 Volt an.
      Ich verstehe diesen Effekt aber überhaupt nicht!

      Brauche ich wirklich nicht die 5V in?
      Ich überlege einen Step-Down einzubauen, der dann die 16.4 16.6 V am Eingang auf 5 V runter regelt.

      Dillbriese schrieb:

      OSD-Kabel der Kamera hättest du an FCam löten können, dann könntest du CameraControl nutzen
      Mache ich sobald alles läuft =)

      Dillbriese schrieb:

      Hast du Smartport invertiert? Wenn nein, musst du das gelbe Kabel des Empfängers nochmal umlöten. Auf LED und dann SoftSerial.
      Nein, denke nicht. Zumindest habe ich außer FW flashen nichts gemacht und einfach direkt angeschlossen. In Betaflight im Bereich Empfänger kommt aber alles korrekt an, wenn ich an der Funke spiele. Dann passt doch alles und die Schritte wären nicht nötig, oder?

      Dillbriese schrieb:

      aber der Hauptstromanschluss am ESC sieht mir aus, als wären die Lötstellen nicht komplett heiß und flüssig gewesen
      Das kann gut sein, werde ich nochmal nachholen.
      Mein Buildlog für andere Einsteiger: Finale Zusammenstellung und Start des Buildlogs (Teilweise kamen noch weitere Komponenten im Laufe des Buildlogs hinzu.)

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Rey ()

    • Rey schrieb:

      Interessant ist übrigens folgendes: Ich habe die Brücke für die Camera einmal versehentlich komplett geschlossen und dann kommt die Start-Melodie des ESCs! Allerdings liegen dann an 5V Out des FCs die 9.34 Volt an.
      Ich verstehe diesen Effekt aber überhaupt nicht!
      Nachtag: Im Video-Signal der Brille ist das Bild stark gestört. Ich sehe viele schwarz/weiße Linien, und Schatten. Wenn ich meine Hand vor der Kamera bewege kann ich eine ähnliche Schattenebwegung im Bild wahrnehmen.
      Mein Buildlog für andere Einsteiger: Finale Zusammenstellung und Start des Buildlogs (Teilweise kamen noch weitere Komponenten im Laufe des Buildlogs hinzu.)
    • Rey schrieb:

      Wie heißt da Zeug genau?
      Ich habe Teslanol T7. Das ist sehr dünn und zum Sprühen. Viele verwenden wohl Plastik 70, das hatte ich noch nicht.

      Rey schrieb:

      Interessant ist übrigens folgendes: Ich habe die Brücke für die Camera einmal versehentlich komplett geschlossen und dann kommt die Start-Melodie des ESCs! Allerdings liegen dann an 5V Out des FCs die 9.34 Volt an.
      Das ist... nicht gut. Die 5V-Schiene versorgt ja praktisch den ganzen FC, den Empfänger usw. - die hast du jetzt alle mit über 9V betrieben. Kann schon sein, dass da jetzt was durch ist.
      Das mit dem step down verstehe ich nicht. Den hat der FC integriert (sogar zwei: 5V und 9V), da brauchst du nichts machen. Achso, meinst du dass der 5V kaputt ist? Na das lässt sich ja leicht prüfen: Liegen normalerweise 5V an oder nicht?


      Rey schrieb:

      In Betaflight im Bereich Empfänger kommt aber alles korrekt an, wenn ich an der Funke spiele. Dann passt doch alles und die Schritte wären nicht nötig, oder?
      Dafür brauchst du SmartPort nicht, das macht schon die SBUS-Verbindung. SmartPort brauchst du nur für die Telemetrie, du wirst auf deiner Taranis also die ganzen Sensoren des FCs nicht empfangen und das Lua-Script geht auch nicht. Ich schätze es kommen nur RSSI und RxBat an, da die direkt vom Empfänger kommen. Dass du auf der (exakt) richtigen Frequenz bist, nehme ich mal an.


      Rey schrieb:

      Nachtag: Im Video-Signal der Brille ist das Bild stark gestört. Ich sehe viele schwarz/weiße Linien, und Schatten. Wenn ich meine Hand vor der Kamera bewege kann ich eine ähnliche Schattenebwegung im Bild wahrnehmen.
      Wenn es über den FC läuft? Du könntest nochmal die PAL/NTSC-Einstellung im Betaflight-OSD prüfen und ggf. an deine Kamera anpassen, aber langsam glaube ich an einen Hardwaredefekt.
    • Ich hab nochmal "normal" verkabelt und die Brücken entsprechend gesetzt. Jetzt liegt wieder an V für Cam und VTX wieder 9,x V an.
      Allerdings (und das war auch schon vorher so) liegen an den 5 V out nur 2 V an, wenn ich das USB Kabel einstecke. Irgendwas ist hier doch verdammt seltsam

      Dillbriese schrieb:

      Dafür brauchst du SmartPort nicht, das macht schon die SBUS-Verbindung. SmartPort brauchst du nur für die Telemetrie, du wirst auf deiner Taranis also die ganzen Sensoren des FCs nicht empfangen und das Lua-Script geht auch nicht. Ich schätze es kommen nur RSSI und RxBat an, da die direkt vom Empfänger kommen. Dass du auf der (exakt) richtigen Frequenz bist, nehme ich mal an.
      Achso okay. Und wie finde ich den LED Pin? Anschließend muss ich LED unbinden und als TX binden, richtig?

      Dillbriese schrieb:

      Du könntest nochmal die PAL/NTSC-Einstellung im Betaflight-OSD prüfen und ggf. an deine Kamera anpassen, aber langsam glaube ich an einen Hardwaredefekt.
      Das steht auf Auto, geändert hatte ich das nicht.

      Seltsam ist wirklich, dass auch der erste FC kein Bild gezeigt hat und auch kein Gepiepe von sich gegeben hat. Beim durchmessen hab ich den ja dann geschrottet und hatte noch einen Backup FC hier liegen. Beide FCs haben exakt das gleiche Fehlerbild --> kein ESC gepiepe und kein OSD.
      Mein Buildlog für andere Einsteiger: Finale Zusammenstellung und Start des Buildlogs (Teilweise kamen noch weitere Komponenten im Laufe des Buildlogs hinzu.)